1. Home
  2. Docs
  3. English: Help & Documentation
  4. HighDesign User Guide
  5. 4. Project Settings

4. Project Settings

Learn how to start a new project and define its settings
Topics in this section
  • Start a New Project
    Learn how to create a new project and customise it to your needs.
  • Project Settings
    Use the Project Settings window to define all aspects of your new project.
    • Paper Format
      Define a default paper size and print margins.
    • Sheet Units
      Set the default drawing units for linear, angular and area values, define the decimal separator and rounding options.
    • Grid
      Your drawing area can show a customisable and scale-sensitive grid.
    • Appearance
      Choose background and selection colours.
    • Project Information (Pro)
      Your project can include a number of non-graphical information about its location, firm, client, etc.

Start a New Project

When you launch HighDesign, the main window opens blank and ready to start a new project. The default new document is generated using the automatic template.

New Project with Automatic Template

To create a new project, you can either click the New button on the Welcome window or select File ▸ New. This new project is generated after the automatic template that sets units, colours and other settings according to the current preferences of language and theme and, when available, the last document created.

The automatic template includes one layer and a limited set of line-types and hatch-types that you can later manage and expand according to your needs.

When your project window is ready, the next step is usually to define the specific project settings such as page format, drawing units, colours and so on. Project settings are specific to the current document.

New Project by Template (Pro)

You can also create a new project starting from a pre-made template that may include a set of layers, sheets, line-types and other resources, as well as drawing objects.

To create a new document from a template, switch to the Templates tab of the Welcome window, or choose File ▸ New from Template Chooser… and select the desired template.


Project Settings

Before starting a new project, it is useful to set up the main settings and drawing utilities according to the drawing standard you wish to use in the current project, such as the paper format and size and the sheet drawing units. 

In HighDesign the Project Settings window, available through the File menu and through the Project menu, includes the panes to set all the default drawing options specific to the current project.

Paper Format

The Paper Format pane lets you select the default paper size of the entire project from a list of standard sizes (ISO, ANSI/ASME and US ARCH) and activate the options for Page orientation and margins. The page standard and size defined in this window is the default for all new layouts. 

  • Once you select the Standard, by clicking on the desired sheet size in the thumbnail, and you choose the “Margins” option (Current Printer or Custom Margins), a visual aid will be displayed on screen showing the page extents of the selected size and the corresponding print margins as a cyan frame: you will use this aid to check if your drawing is entirely within the margins.
  • The Global Settings section lets you set the page margins that will be visible in all pages of the project if the Margins option is active.

The default paper format can be overridden by a custom selection in the Paper Size panel that is available in the Object Info panel. To access the Paper Size pane:

  • Activate the desired sheet on the Project Browser panel and make sure no object is selected. The Object Info panel shows the current paper format and size.
  • Alternatively, double-click the sheet icon on the Project Browser.

Manage Custom Sizes window

You can access this window via the Standard menu to create and manage custom paper sizes. A custom paper size can have user-defined size and margins, or it can inherit the actual values from an installed printer. Click the “Define by Printer” button to open the system printer dialog to select a printer and a paper size. 

Saved presets can be renamed, edited and duplicated and deleted at any time. They are also available in the Paper Size windows of sheets and layouts.

Sheet Units

Use this pane to define your preferences for the default, project-wide measurement units for lengths, angles and surfaces. 

 The available options are: 

  • Linear units, available as Millimeters, Centimeters, Meters, Kilometers, Decimal Inches, Feet and Decimal Inches, Decimal Feet, Fractional Inches, Feet and Fractional Inches, Decimal Yards, Miles, Points and Pixels; the number of decimal digits to be displayed;
  • Angular units, selectable from Decimal Degrees, Degrees and Minutes, Degrees,
    Minutes and Seconds; the number of decimal digits to be displayed when in decimal degrees; the option to use normal angles, bearings or azimuth; the direction of the North used by bearings and azimuth directions;
  • Area units used to express area calculations and values;
  • The decimal separator to use;
  • Suppression of zero digits (not available in HighDesign Lt). 

Grid

You can use this pane to customize the grid and set grid options: 

  • Horizontal and vertical size; 
  • Number of subdivisions; 
  • Grid color: automatic (changes with the current background color) or custom; 
  • Option to display the grid behind or in front of the drawing; 
  • Option to print the grid; 
  • Option to set the snap to grid as exclusive; 
  • A button to show / hide the grid;

Appearance

This pane lets you customize your HighDesign work environment. You can: 

  • Choose a background color;
  • Select the color of selection handles;
  • Choose to highlight selected objects;Choose the color of construction lines: by object (through the Properties bar) or custom;
  • Set the line-type of construction lines as continuous or dashed.

Project Information  (Pro)

Use this pane to add non graphic information to a project, such as author, project name, description, client name, project location, status or to set an issue date of the project; Project Time shows you the time you have spent on the project. 

Most of these information correspond to the attributes of the Title Blocks and will be automatically added to the title blocks used in the Layouts of the project. 

Was this article helpful to you? Yes No

How can we help?