1. Home
  2. Docs
  3. English: Help & Documentation
  4. HighDesign Quick Start Guide
  5. Basic Tasks

Basic Tasks

Create and Set Up a New Project

When you launch HighDesign, it automatically creates a blank project with settings based on the last project that was saved, or on the defaults if it is the first launch. You can then customize this project to your needs and set units, create sheets, layers, add palettes; alternatively, in HighDesign Pro you can open a template and start from there.

Use the Preferences window (HighDesign > Preferences on macOS, Edit > Options on Windows) to set the options that best suit your workflow and habits and are most likely to stay the same for each new project. In the Preferences window you can set the language, the file safety options to create and archive backup copies, the theme of the user interface, default drawing settings, etc.

Organize Your Project

When you start a new project, you typically want to prepare it for the kind of objects that it will represent: drawing scales, units, sheets, layers can be prepared in advance by using the Project Settings window (Project > Project Settings) and the Resource Manager window (Project > Resource Manager).

Essential Sketching Skills

To construct a new object, activate its icon from the toolbox, select the appropriate method and begin the construction on the main drawing area. By default, the step-by-step instructions appear on the Status bar.

To select an object:
  • With the Arrow tool:
    • click it once, or
    • hold Shift and click to add it to or remove it from the selection,
    • or define a rectangular or polygonal region to select the items enclosed.
  • With any drawing tool:
    • Shift-click the object, or
    • Right-click the object
  • With the Find function:
    • Choose Edit > Find and use the Find panel to define the search criteria.

When two or more objects are overlapped, activate the Arrow tool and right click on them. The contextual menu lists all the objects at the click location in reverse order.

To edit an object:
  • Use the Arrow tool to change the basic geometry of the object, i.e. its bounding box.
  • For more object-specific editing, for example adjusting the tangents of a curve or moving the origin of a hatch, activate its tool and click the handle or part of the object that you want to modify.
  • To edit the coordinates, size and other options of the object, use the Object Info panel.
To enter a coordinate:
  • Push the X or Y keys on the keyboard, or push Tab to cycle between inputs.
  • Enter the start coordinate in its absolute value, i.e. the X- or Y- coordinate from the origin point of the current sheet.
  • To enter the end coordinate, repeat the above to enter the absolute value, or click the X icon in the input field to change to relative coordinates. In relative coordinates, the value will be calculated from the start point of the current operation.
To enter a length:
  • While drawing, enter a numeric value. The keys pressed will be interpreted as a linear value for the current operation. If entered while drawing an item, the value will be used as the length of the item; if no drawing operation was active, the value will be interpreted as initial distance from a reference point defined by the next click.

Was this article helpful to you? Yes 3 No 1

How can we help?