1. Home
  2. Docs
  3. Italiano: Aiuto e Documentazione
  4. Guida Utente
  5. 13. Strumenti di Disegno

13. Strumenti di Disegno

Creare forme e oggetti geometrici di base
Argomenti in questa sezione

Tecniche di base nella stesura di disegni

Il processo di base per disegnare qualsiasi oggetto in HighDesign consiste nel selezionare lo strumento desiderato, scegliere un metodo di disegno tra quelli disponibili nello strumento e cliccare sull’area di disegno per iniziare la costruzione dell’oggetto. Se ci sono oggetti selezionati, il primo clic deseleziona tutto.

I nuovi oggetti vengono creati utilizzando gli attributi grafici e le proprietà predefinite correnti: livello, tratto e riempimento, tipo di linea, ecc. Se l’oggetto che si sta creando è un elemento, cioè un oggetto più complesso di una forma di base come i tratteggi o i testi, è possibile impostare i valori predefiniti specifici attraverso la sua finestra delle Impostazioni. Fate doppio clic sull’icona dello strumento nella casella degli strumenti per aprire la finestra delle impostazioni per quella classe di oggetti.

Gli attributi e le proprietà possono anche essere cambiati in qualsiasi momento dopo che l’oggetto è stato creato: seleziona l’oggetto e cambia le proprietà desiderate.

Tecniche di Disegno

La procedura di disegno predefinita adottata in HighDesign è “Clic-Muovi-Clic”, cioè per disegnare una linea si clicca per impostare il punto iniziale, si sposta il puntatore nella posizione desiderata e si clicca nuovamente per impostare il punto finale. È supportato anche il clic e trascinamento. Puoi cambiare il metodo di disegno in Preferenze ▸ Disegno

Per annullare un’operazione potete premere il tasto Esc sulla tastiera, o premere il tasto destro del mouse. 

Gli oggetti multi-segmento, come polilinee, tratteggi, percorsi, seguono lo stesso metodo generale: cliccate per definire i vertici, fate doppio clic o premete il tasto Esc per terminare.

Le procedure generali di redazione descritte sopra sono valide anche per gli strumenti di Drafting, Documentazione e Progettazione.


Selezione

Lo strumento freccia permette di selezionare gli oggetti del disegno cliccando direttamente su di essi o definendo un’area di selezione. Per selezionare un oggetto, cliccate su di esso con lo strumento freccia. Lo strumento Snap to Objects deve essere attivo in modo che lo strumento freccia possa “vedere” l’oggetto che si sta cliccando. 

Metodi

Selezione rettangolare

Cliccate su una parte vuota dello schermo e spostate il puntatore per definire un rettangolo: gli oggetti con punti di controllo all’interno del rettangolo saranno selezionati. 
Se ti muovi dall’alto verso il basso, la selezione includerà tutti gli oggetti parzialmente o completamente racchiusi (selezione inclusiva); se ti muovi dal basso verso l’alto, la selezione includerà solo gli oggetti completamente racchiusi (selezione esclusiva). È possibile invertire la modalità di selezione in qualsiasi momento tenendo premuto il tasto Alt (Opzione).

Modalità di selezione inclusiva ed esclusiva

Selezione poligonale

Usa questo metodo per selezionare gli oggetti definendo una regione poligonale. Fare clic per aggiungere un vertice alla regione di selezione, fare doppio clic per terminare.

Aggiungere e rimuovere oggetti

Tieni premuto il tasto Shift mentre clicchi per aggiungere elementi alla selezione o rimuovere elementi già selezionati. Clicca su una parte vuota dello schermo per deselezionare tutto. Se l’opzione “Lo strumento freccia fa clic per estendere la selezione” è attiva nelle Preferenze, facendo clic su un oggetto non selezionato, questo verrà automaticamente aggiunto alla selezione.

Selezione di oggetti sovrapposti

Quando due o più oggetti si sovrappongono può essere difficile selezionare l’oggetto giusto. Per ottenere una selezione intelligente, attivate lo strumento Freccia, tenete premuto il tasto Control e cliccate o cliccate con il tasto destro sull’intersezione per aprire un menu contestuale con un elenco di tutti gli oggetti in quella posizione, dall’alto verso il basso.

Modifica degli oggetti

Lo strumento Freccia può anche essere usato come uno strumento di modifica universale: la maggior parte delle azioni di modifica specifiche dello strumento, come il ridimensionamento di una linea o la modifica di un testo, possono anche essere eseguite con lo strumento Freccia.

  • Cliccando un oggetto selezionato sul suo contorno, ma non su un vertice, si attiva la funzione Move.
  • Cliccando su un vertice di un oggetto si ridimensiona l’oggetto.
  • Passando il cursore su un vertice di un tratteggio, polilinea o spline selezionato si apre il menu con le opzioni per modificare il vertice.
  • Tenere premuto il tasto Command per spostare qualsiasi oggetto, selezionato o non selezionato, per uno qualsiasi dei suoi vertici o per il suo contorno. 

Oggetti di costruzione

Lo strumento Oggetti di costruzione può essere usato per marcare elementi di riferimento e oggetti ausiliari nel disegno. Ha tre modalità: punto, per creare punti di riferimento nel disegno; linea di costruzione, per aggiungere linee infinite per allineamenti e margini; origine, per impostare l’origine del sistema di coordinate nel disegno corrente. 

Metodi

Punto di riferimento

Cliccare sulla posizione desiderata per inserire un punto o premere i tasti X e Y sulla tastiera per inserire le sue coordinate. Nella finestra Stampa si può scegliere di stampare i punti di riferimento e le linee di costruzione.

Linea di costruzione

Questo metodo permette di creare linee infinite: cliccare per impostare il centro e la direzione o inserire l’angolo premendo il tasto A sulla tastiera o cliccare su un oggetto lineare esistente per disegnare una linea di costruzione parallela. Per impostare la distanza della linea di costruzione dall’oggetto lineare di riferimento, premere il tasto L sulla tastiera, inserire il valore e cliccare sulla posizione desiderata.

Le linee di costruzione possono anche essere disegnate come guide orizzontali e verticali: trascinarle dai righelli nella posizione desiderata. Le linee di costruzione possono essere spostate con lo strumento Freccia.

Questo metodo consente di creare guide, cioè linee infinite che servono come riferimenti nel disegno. Le linee di costruzione possono essere create con due metodi:

Guide dai righelli

Quando i righelli sono visibili nell’area di disegno principale (Vista ▸ Mostra righelli), fare clic e trascinare sul righello orizzontale o verticale per posizionare una guida allineata. Durante il trascinamento è possibile agganciarsi agli oggetti del disegno per posizionare la guida nella posizione desiderata. Questo metodo funziona con qualsiasi strumento di disegno.

Guide da punto

Con questo metodo è possibile creare una linea di costruzione orientata ad un angolo arbitrario.

  1. Attivare lo strumento Oggetti di costruzione > Metodo Linee di costruzione.
  2. Fare clic per impostare il centro e definire la direzione con il puntatore. È possibile inserire un angolo definito premendo il tasto A della tastiera o facendo clic su un oggetto lineare esistente per tracciare una linea di costruzione parallela. Per impostare la distanza della linea di costruzione dall’oggetto lineare di riferimento, premere il tasto L della tastiera, inserire il valore e fare clic sulla posizione desiderata.

Per creare una guida parallela a una guida esistente, come se fosse un duplicato: con il metodo Linee di costruzione, fare clic su una linea di costruzione non selezionata nel disegno e spostarsi. Utilizzare la tastiera per inserire una distanza vincolata.

Modifica di una linea di costruzione

Le linee di costruzione possono essere spostate come qualsiasi altro oggetto: selezionare la linea, fare clic su un punto qualsiasi e spostare il puntatore. Per limitare la traslazione a una distanza definita, immettere direttamente la lunghezza desiderata e premere Return o Invio.

Origine assoluta

Clicca per cambiare l’origine degli assi cartesiani e dei righelli. Le coordinate del disegno e le dimensioni vengono aggiornate automaticamente. Potete anche cambiare l’Origine usando il pulsante sull’intersezione dei righelli. In HighDesign Professional ogni foglio ha la propria Origine. 


Linee

Probabilmente uno degli strumenti più utilizzati, lo strumento Linea permette di tracciare linee rette di qualsiasi lunghezza e angolo da un punto iniziale a un punto finale. 

Metodi

Linea singola

Un segmento di linea da un estremo all’altro.

Linea per centro

Crea un segmento di linea dal suo punto medio.

Linea segmentata

Crea una serie di linee collegate. Clicca per impostare il primo vertice, poi clicca per impostare il vertice successivo. Per terminare la serie, fai doppio clic sull’ultimo vertice. Ogni segmento è una linea separata.

Doppia linea

Crea due segmenti paralleli della stessa lunghezza all’offset specificato. Attiva il campo Offset accanto alle icone del metodo per inserire un valore. Le linee doppie possono essere tracciate dall’asse o da un lato.

Il metodo standard per disegnare una linea di una data lunghezza è quello di impostare il primo punto, premere il tasto L (o la scorciatoia corrispondente), inserire il valore e premere il tasto Return. La stessa procedura vale per Angolo (A), X, Y. Altri metodi sono descritti nel capitolo Operazioni di base.

Per ridimensionare una linea, selezionarla e con lo strumento Linea attivo cliccare su un punto finale. Cliccare sul suo punto medio per spostarla. 


Polilinee

Lo strumento Polilinea crea una forma poligonale fatta di una serie collegata di segmenti dritti e curvi. I segmenti curvi sono archi disegnati per centro o per tangente. 

Per disegnare una polilinea, clicca per impostare il primo vertice, poi clicca per impostare il vertice successivo. Per terminare la catena, fai doppio clic sull’ultimo vertice.

Durante la creazione di una polilinea, un’icona di azione segue il punto di inizio di ogni segmento. Fai clic su di essa o passa il mouse su di essa per aprire il menu delle opzioni e scegliere il tipo di segmento successivo, cancellare l’ultimo segmento o terminare la forma. Per chiudere la polilinea, seleziona l’opzione corrispondente o posiziona l’ultimo vertice sul primo. Le polilinee hanno l’opzione di riempimento disponibile nella Barra delle proprietà.

Modificare una polilinea

Una polilinea può essere modificata in diversi modi: attivare lo strumento Polilinea e selezionare l’oggetto (se non è già selezionato); poi:

  • fare clic su un vertice per allungarlo
  • cliccare su un punto medio per spostare l’intero segmento
  • cliccare su un segmento per aggiungere un vertice
  • posizionare un vertice sopra un altro vertice per cancellarlo
  • passare il cursore su un vertice per aprire il menu Modifica

Il pannello informativo dell’oggetto fornisce più opzioni di modifica:

  • Trascina il cursore Convessità per cambiare la convessità del segmento corrente. Questa opzione può facilmente convertire un segmento dritto in un arco e viceversa. Il valore del Raggio viene aggiornato automaticamente quando si usa il controllo della convessità: si può anche impostare il valore del raggio numericamente.
  • Usate l’interruttore Chiuso per chiudere la polilinea. Il segmento di chiusura prende lo stesso tipo dell’ultimo segmento aggiunto.

Poligoni

Usa questo strumento per disegnare rettangoli, quadrati e poligoni regolari di qualsiasi numero di lati.

Metodi

Rettangolo

Per disegnare un rettangolo, clicca per impostare il primo vertice, sposta il puntatore e clicca di nuovo per impostare il vertice opposto. È possibile aggiungere diagonali a un rettangolo premendo il tasto Opzione al secondo clic. Per disegnare un quadrato, usate lo strumento rettangolo e tenete premuto il tasto Shift per vincolare la direzione della diagonale. 

Per impostare la dimensione del rettangolo, clicca per impostare il vertice di partenza, poi premi il tasto “W” per impostare la larghezza e “H” per impostare l’altezza. I valori positivi vanno verso destra e verso l’alto. Per modificare il rettangolo con lo strumento Freccia o lo strumento Disegno attivo, clicca sui vertici per ridimensionare, sui punti medi dei lati per allungare, e clicca sui lati o sul punto centrale per spostare.

Rettangolo ruotato

Clicca per posizionare il primo vertice, sposta il puntatore e clicca di nuovo per impostare l’angolo di base; poi sposta il puntatore e clicca una terza volta per impostare l’altezza della forma. Per impostare le dimensioni, clicca sul primo vertice, premi il tasto “A” per impostare l’angolo, il tasto “W” per la larghezza e il tasto “H” per l’altezza.

Rettangolo dal centro

Clicca per impostare il centro del rettangolo; sposta e clicca per definire l’orientamento e il primo asse; sposta e clicca di nuovo per definire l’asse perpendicolare.

Poligono regolare dal raggio esterno

Questo metodo permette di disegnare poligoni regolari con qualsiasi numero di lati a partire da tre. Per impostare il numero di lati desiderato, utilizzate il campo offset nella barra dei metodi accanto ai metodi degli strumenti e inserite il valore. 

Per disegnare un poligono regolare con il raggio esterno, clicca per impostare il centro della forma (tutti questi poligoni regolari sono inscritti in un cerchio), sposta il puntatore e clicca di nuovo per impostare il raggio del cerchio circoscritto e il vertice del poligono.

Poligono regolare dal raggio interno

Questo metodo permette di disegnare il poligono impostando il centro e il raggio del cerchio inscritto nel poligono.

Poligono regolare dal lato

Crea un poligono definito dal lato. Per creare il poligono, disegna il primo lato, esattamente come una linea della lunghezza e dell’angolo desiderati, e clicca nuovamente per posizionare la forma nella posizione desiderata. 


Retini e riempimenti

Usate lo strumento tratteggio per riempire regioni poligonali con un colore, un tratteggio vettoriale lineare, un motivo vettoriale a piastrelle o una texture. Questo strumento ha quattro metodi: Retino (poligono), Retino al clic, Isole poligonali e Isole circolari.

I retini possono essere scelti da una lista di tipi: HighDesign viene fornito con una vasta gamma di tratteggi incorporati che possono essere facilmente estesi con i vostri retini personali. Potete anche combinare riempimenti e retini. 

Per impostare o modificare gli attributi dei tratteggi, selezionare Modifica ▸ Finestra delle impostazioni ▸ Modello di retino o fare doppio clic sull’icona corrispondente nella barra degli strumenti per aprire la finestra Impostazioni tratteggio e riempimento. 

Finestra delle impostazioni dei tratteggi e dei riempimenti

La finestra delle impostazioni visualizza tutte le opzioni per le proprietà grafiche specifiche dello strumento e i controlli e i campi per la configurazione dello strumento.

Sulla barra superiore della finestra di dialogo, vicino al titolo, è disponibile il pulsante triangolare per selezionare e caricare gli stili esistenti: sulla destra c’è l’icona Aggiungi che permette di creare un nuovo stile con le impostazioni correnti. Queste caratteristiche generali della barra del titolo della finestra delle impostazioni sono condivise da tutti gli strumenti di disegno con impostazioni specifiche. 

Le opzioni delle impostazioni sono:

  • Bordo: selezionare per mostrare il bordo della regione tratteggiata e selezionare il suo colore.
  • Riempimento: selezionare per aggiungere un colore solido o un riempimento a gradiente. Utilizzare il pulsante del colore di riempimento per selezionare il colore e le opzioni.
  • La casella di controllo Tratteggio/Texture abilita il tratteggio vettoriale della regione; il colore del tratteggio può essere selezionato tramite il menu Colore penna sulla barra delle proprietà.
  • Fattore di scala: utilizzare questo cursore per scalare gli spazi e gli offset del tratteggio o per ridimensionare la mattonella della texture.
  • Disegna in scala: regola la scala del tratteggio in modo che corrisponda alla scala del foglio corrente, in modo da ridimensionare il tratteggio di conseguenza. Questa opzione è particolarmente utile quando il tratteggio rappresenta un elemento di costruzione reale come un pavimento o un muro. 
  • Rotazione: controlla l’angolo di rotazione di tutti i modelli del tratteggio. Le texture possono ruotare solo di 90 gradi.
  • Tabella dei retini: elenca tutti i retini, patter e texture presenti nel progetto.
  • L’ultima cella della tabella Tratteggi è un pulsante speciale: cliccalo per aggiungere tipi di tratteggio al progetto corrente. Questa opzione apre il pannello “Hatch patterns” della finestra Resource Manager. 

Disegnare e modificare un tratteggio / riempimento

  • Per disegnare una regione di tratteggio/riempimento, usare questo strumento allo stesso modo dello strumento Poly-line o selezionare un poligono esistente e scegliere Strumenti ▸ Applica tratteggio. Mentre si disegna una regione di tratteggio/riempimento, è possibile cancellare l’ultimo vertice con un clic sull’icona X vicino ad esso. 
  • Per modificare un vertice di una regione di tratteggio, selezionare l’oggetto e, con lo strumento tratteggio attivo, spostare il puntatore sul vertice fino a quando non appare il menu degli strumenti con le opzioni di modifica. 
  • Per aggiungere un vertice, clicca su un lato o clicca sull’opzione “Add Vertex” del menu; per cancellare un vertice, sposta il puntatore su quel vertice e clicca sull’opzione corrispondente del menu degli strumenti. 
  • L’opzione “Fit arc at click” appare quando il puntatore è sopra il punto di inizio di un arco e permette all’utente di modificare il tratteggio selezionato e di adattare l’arco con un clic.

I retini possono anche essere inseriti su forme omogenee con un clic sul loro contorno. 

I retini e i riempimenti possono ospitare aperture multiple di forme poligonali e circolari. Queste aperture sono chiamate isole e ci sono due diversi metodi di strumenti per crearle.

Metodi

Regione poligonale

Per definire una regione poligonale tratteggiata, cliccate su ogni vertice della regione e fate doppio clic per terminare.

Retino al clic

È possibile applicare il tratteggio corrente a forme omogenee come Poli-linee, rettangoli, poligoni, cerchi, archi, ellissi e curve con un clic: basta attivare il metodo e cliccare sul contorno della forma che si desidera tratteggiare. 

Le regioni racchiuse da muri collegati possono essere tratteggiate con un clic all’interno.

Isola poligonale

Selezionate questo metodo per creare aperture poligonali nei tratteggi esistenti disegnando le forme delle isole all’interno della selezione. Per farlo, basta attivare lo strumento tratteggi e riempimenti, selezionare il metodo e cliccare sui vertici dell’apertura poligonale che si vuole creare all’interno del tratteggio. Questo metodo può essere usato sia sui tratteggi selezionati che su quelli non selezionati. Il tratteggio più vicino viene rilevato automaticamente quando si sposta il cursore sul progetto.

Isole circolari

Questo metodo permette di aprire isole circolari definite dal centro e dal raggio. Clicca per impostare il centro e clicca di nuovo per impostare il raggio: è anche possibile impostare il valore del raggio numericamente.

Per modificare un’isola, seleziona il tratteggio e posiziona il puntatore su un vertice dell’isola finché il menu degli strumenti non appare dandoti le opzioni per rimuovere l’isola, cancellare un vertice o aggiungerne un altro. 


Cerchi, archi, ellissi

Usate questo strumento per disegnare cerchi, archi, ellissi e archi di ellisse. Tutti i metodi per gli archi circolari possono essere utilizzati per disegnare cerchi completi cliccando l’interruttore che appare sullo schermo accanto al primo punto dell’arco, o tenendo premuto il tasto Alt. 

La costruzione può essere sia grafica, tramite clic sul disegno, sia numerica tramite l’input della tastiera. 

Metodi 

 Arco/Cerchio per centro e raggio

Per disegnare un arco o un cerchio clicca per impostare il centro (o impostalo con le coordinate), poi seleziona l’opzione arco o cerchio sul pulsante fluttuante sullo schermo.

Per disegnare un arco, impostate il raggio premendo il tasto L, impostate l’angolo iniziale premendo il tasto A e impostate l’angolo finale premendo nuovamente A. Per disegnare un arco graficamente, sposta il puntatore e clicca di nuovo per impostare l’angolo iniziale; con il prossimo clic definisci l’angolo finale dell’arco. 

Per disegnare un cerchio completo, impostate la lunghezza del raggio premendo il tasto L sulla tastiera e l’angolo iniziale / finale premendo il tasto A. Premere Return per confermare.

Arco/Cerchio per diametro

Clicca per impostare il primo vertice del diametro, sposta il puntatore e clicca di nuovo per impostare il secondo vertice. Puoi definire il diametro premendo il tasto L, e l’angolo premendo il tasto A. 

Arco/Cerchio per punto iniziale, punto finale, raggio

Clicca per impostare il punto iniziale e finale dell’arco e clicca per impostare il raggio. I due punti e il raggio possono anche essere definiti tramite input numerico usando le coordinate X, Y e Dx, Dy e il valore L. Tieni premuto il tasto “alt” per cambiare la direzione dell’arco.

Arco/Cerchio da tre punti

Clicca per impostare i punti che definiscono l’arco. I tre punti possono anche essere definiti tramite input numerico usando le coordinate X, Y o i valori L e A.

Arco/Cerchio per tangente

Cliccare sul punto finale di una linea o sul punto finale di un arco per impostare il primo punto dell’arco disegnato dalla tangente a quell’oggetto in quel punto finale del dato. 

Ellisse per rettangolo di delimitazione

Impostare il punto iniziale, spostare e definire il punto finale della diagonale. L’ellisse è inscritta nel rettangolo definito dalla sua diagonale. 

Ellisse per centro e raggi

Cliccare per impostare il centro dell’ellisse, spostare e cliccare per definire il suo primo raggio; spostare nuovamente e cliccare per impostare il suo secondo raggio. Il centro può anche essere definito usando le coordinate X, Y e i raggi possono essere definiti premendo il tasto L durante la loro costruzione. 

Quarto di ellisse

Questo metodo permette di disegnare quarti di ellisse cliccando sui suoi due vertici.   


Curve

Lo strumento Curve permette di disegnare curve di Bézier singole e multiple, linee a mano libera, curve Spline e nuvole. 

Metodi 

Curve di Bézier

Questo metodo può essere usato per disegnare percorsi di Bézier multipli e connessi, curve parametriche definite da due vertici e due linee tangenti: 

  • clicca per impostare il primo vertice, sposta il puntatore e clicca per impostare il vertice successivo; doppio clic per terminare la catena di curve di Bezier.
  • Per disegnare una curva durante la costruzione, cliccare e trascinare per definire il suo profilo.

Il tracciato risultante può essere modificato per smussare i vertici e trasformare i segmenti dritti nelle curve desiderate: in questo modo la prima tangente della curva successiva è sempre definita da quella precedente. Le curve di Bézier hanno la proprietà di riempimento: selezionare il colore desiderato nel menu “Colore di riempimento” della barra delle proprietà. Modificare una curva di Bézier 

  • Passa il cursore su un vertice della curva selezionata per mostrare il menu a comparsa con le opzioni per aggiungere o eliminare vertici e smussare o affinare il percorso creando curve connesse o segmenti rettilinei.
  • Cliccando su uno dei quattro punti di controllo di una curva selezionata, potete cambiare la sua posizione e regolare visivamente il profilo. Con curve di Bézier multiple, modificando un punto di definizione le tangenti collegate sono vincolate a mantenere lo stesso angolo: spostate i punti di controllo delle tangenti per cambiare l’angolo e regolare la forma della curva. 
  • Tieni premuto il tasto Alt mentre muovi i punti di controllo delle tangenti per modificare asimmetricamente; tasto Alt + tasto Cmd per separare le tangenti.

Linea a Mano Libera

Il metodo a mano libera permette di creare curve spline seguendo il movimento del cursore. Il metodo a mano libera ha due proprietà: il fattore di lisciatura, che definisce la complessità della curva, e l’opzione di disegno. Potete regolare il fattore di lisciatura dei nuovi tracciati attraverso la finestra delle impostazioni a mano libera: 1 significa che il tracciato manterrà la sua forma originale, ma potrebbe avere molti vertici; 6 è lo smussamento massimo e il tracciato sarà notevolmente semplificato.

Nello stesso pannello, si può anche scegliere di disegnare percorsi a mano libera con un metodo click-drag invece dello standard click-click: questa opzione è particolarmente utile quando si usa una pen tablet, perché permette un modo più naturale di disegnare con una penna.

Spline 

Le curve spline in HighDesign sono B-spline cubiche, curve continue disegnate attraverso un dato insieme di punti: per creare una curva spline, cliccate per impostare i punti che definiscono la forma della curva. Doppio clic sull’ultimo punto per terminare la curva. Scegliere il colore di riempimento dal menu corrispondente della barra delle proprietà. 

Modifica di una curva Spline e di un tracciato a mano libera
  • Passare il cursore su un vertice della curva selezionata per mostrare il menu a comparsa con le opzioni per aggiungere o eliminare punti;
  • Spostare i punti dati della curva selezionata con lo strumento Freccia o con il puntatore e il metodo dello strumento Spline o a mano libera attivo. 

Nuvola di revisione

Con questo metodo si può creare un gruppo fatto di catene di archi collegati. È possibile utilizzare questo strumento per disegnare un insieme personale di nuvole di revisione da salvare come simboli per usi futuri.


Simboli

Lo strumento Simboli è uno strumento di disegno che ti permette di inserire nel tuo progetto interi disegni o porzioni di disegni già creati e memorizzati in una libreria con un solo clic. L’uso dei Simboli è un modo conveniente per riprodurre molte volte lo stesso gruppo di elementi con fattori di rotazione, rispecchiamento e scala indipendenti. 

I simboli possono memorizzare attributi, che sono informazioni visualizzate nella posizione desiderata della vista corrente.

Per modificare o impostare le proprietà dello strumento simbolo, selezionare Modifica ▸ Finestra impostazioni ▸ Simbolo o fare doppio clic sull’icona dello strumento simbolo nella barra degli strumenti di disegno.

Finestra delle impostazioni dei simboli 

La finestra di dialogo delle impostazioni del simbolo ha due riquadri: Simbolo e Attributi. Il riquadro Simbolo fornisce molte opzioni per scegliere un nuovo simbolo e impostare le sue proprietà grafiche. 

  • La tabella elenca la cartella della libreria attualmente selezionata: questa cartella può contenere molte sottocartelle e può essere organizzata a tua scelta. Sfogliate questa tabella per selezionare il file del simbolo. 
  • Una volta selezionato un simbolo, appare un elenco di tutte le sue viste, se disponibili: selezionare una vista dalla lista per attivarla; fare doppio clic sul suo nome per cambiarlo e cliccare sull’icona della matita per modificare il simbolo/vista (solo per i simboli personalizzati). 
  • La casella di anteprima mostra una miniatura del simbolo selezionato con i parametri correnti. 
  • I parametri geometrici del simbolo sono: larghezza, altezza (che può ridimensionarsi proporzionalmente), angolo (in gradi); sotto i campi di input, i pulsanti Trasformazioni rapide permettono il mirroring del simbolo. Le proprietà del simbolo sono le opzioni di riempimento e colore e l’opzione per scalare il simbolo in modo corrispondente alla scala corrente del disegno. 
  • In basso sono raggruppati i pulsanti per (da sinistra a destra) creare una nuova cartella, creare un nuovo simbolo dagli oggetti selezionati, duplicare il simbolo selezionato, aggiungere una nuova vista ad un simbolo esistente e cancellare l’elemento selezionato.

Il pannello Attributi visualizza gli attributi opzionali della vista corrente. Usate questo pannello per impostare i valori degli attributi del simbolo o della vista simbolo che state inserendo nel progetto o per cambiare i valori della selezione corrente.

Creare e modificare i simboli

Le funzioni “Nuovo Simbolo” e “Modifica Simbolo”, disponibili anche attraverso il menu Progetto, quando attivate passano a un’area di lavoro diversa con un set limitato di strumenti: in questo ambiente è possibile disegnare, modificare e salvare simboli e viste di simboli. 

Si può creare un nuovo simbolo da zero o creare un nuovo simbolo dalla selezione: in questo caso si può anche attivare questa funzione attraverso il Menu radiale per un flusso di lavoro più veloce. In questo modo gli oggetti selezionati sono ora visibili nell’ambiente “Modifica Simbolo” mentre tutti gli altri elementi del disegno sono nascosti. 

Creare un nuovo simbolo

  • Selezionare “Nuovo Simbolo” nel menu Progetto; 
  • L’ambiente passa al contesto “Modifica Simbolo” con un set limitato di strumenti e si apre la finestra di dialogo “Nuovo Simbolo”; questa finestra è divisa in quattro sezioni:
  • File del simbolo
  • Vista
  • Attributi
  • Punti d’inserimento
  • Disegna il simbolo;
  • Digita il nome del simbolo; 
  • Seleziona la cartella di destinazione tramite il pulsante della cartella; 
  • Usa il pulsante “+” per aggiungere una nuova vista; 
  • Digita il nome della vista; 
  • Imposta gli eventuali attributi;
  • Inserisci gli attributi nel disegno della vista del simbolo;
  • Posiziona i punti di inserimento nelle posizioni desiderate della vista simbolo;
  • Premi il pulsante “Salva” sulla finestra di dialogo. 

Attributi del simbolo

Gli attributi sono informazioni aggiunte alla vista corrente del simbolo: queste informazioni sono definite da un ID, un titolo e un valore di Default che sarà visualizzato nel progetto.

La sezione Attributi della finestra di dialogo Nuovo simbolo mostra: 

  • Il menu degli attributi esistenti della vista (visibile quando si modifica un simbolo e i suoi attributi);
  • Il pulsante Aggiungi per creare un nuovo attributo;
  • Il pulsante per rimuovere gli attributi selezionati,
  • Il pulsante “Modifica attributo” per modificare l’attributo attualmente selezionato.

Dato che gli attributi sono una sottoclasse del testo, possono ottenere proprietà del testo come font, dimensione del carattere, allineamento, stile e angolo di rotazione: la finestra “Definisci Attributie” mostra tutte queste informazioni e opzioni.

Per inserire l’attributo, basta cliccare sulla posizione desiderata della vista simbolo.

Modificare un simbolo

Per modificare un simbolo si può cliccare sul pulsante Modifica del simbolo selezionato nella finestra Impostazioni, oppure selezionare il simbolo sul disegno e scegliere “Modifica simbolo” nel menu Progetto o usare il Menu radiale. 

Si apre l’area di lavoro “Edit Symbol” e si può modificare il simbolo, aggiungere viste al simbolo premendo il pulsante “+” della finestra di dialogo o eliminare le viste attraverso il pulsante “-“, cambiare gli attributi della vista.

Premendo il pulsante “Salva”, l’ambiente torna a “Disegno”. Le modifiche apportate ad un simbolo sono immediatamente visibili in tutti i duplicati di simboli del disegno. 

Inserire un simbolo nel disegno 

  • Aprire la finestra di dialogo Libreria dei simboli scegliendo Modifica ▸ Finestra impostazioni ▸ Simbolo o facendo doppio clic sull’icona Simbolo nella barra degli strumenti Disegno; 
  • Selezionare un simbolo nella tabella delle cartelle e scegliere una delle viste disponibili; 
  • Impostare le sue dimensioni e i parametri opzionali; 
  • Rivedere o cambiare gli attributi predefiniti, se disponibili;
  • Fare clic su uno dei punti di inserimento definiti, sul centro o su uno dei vertici o punti medi della miniatura per selezionare il punto di inserimento corrente; 
  • Trascinare l’anteprima sul disegno o cliccare sul punto desiderato del disegno. 

Per creare un nuovo simbolo, per aggiungere una vista ad un simbolo o per modificare un simbolo esistente, sono disponibili anche i comandi specifici del menu Progetto. 


Immagini

Le immagini in HighDesign possono essere inserite tramite il comando di menu Inserisci Immagine. I tipi di file supportati sono TIFF, JPG, PNG, GIF e PDF. I livelli alfa presenti nei file TIFF e PNG sono conservati. Una volta inserita nel progetto, l’immagine viene trattata come un oggetto vettoriale con coordinate, larghezza, altezza e parametri di angolo.

Inserire un’immagine

HighDesign permette di aggiungere facilmente immagini al vostro progetto da diversi formati grafici (TIFF, JPEG, PNG, GIF, BMP, PDF). Le immagini inserite nel progetto mantengono la loro risoluzione e sono visualizzate alle dimensioni reali di stampa: è possibile gestirle come qualsiasi altra entità vettoriale. Le immagini PNG e TIFF sono importate con il loro canale alfa se presente. 

Potete inserire un’immagine nel vostro progetto in diversi modi:

  • File ▸ Inserisci immagine…
  • Progetto ▸ Inserisci ▸ Immagine…
  • Fare doppio clic sull’icona dello strumento Immagine per aprire il pannello delle impostazioni, premere il pulsante Apri immagine e il pulsante Apri sul pannello a comparsa.
  • Trascina e rilascia un file immagine dal computer.
  • Trascina e rilascia un’immagine da un’altra applicazione, come un browser web o un software di archiviazione foto.
  • Incolla un’immagine dagli appunti di sistema.

Lo strumento Insert Image fornisce una finestra a comparsa per la selezione rapida di immagini utilizzate nel progetto corrente o caricate di recente.

I documenti PDF possono essere inseriti come immagini ad alta risoluzione. Quando si sceglie un documento PDF con il comando Insert Image, viene presentata una finestra di dialogo in cui è possibile selezionare la pagina da importare, se più di una, e impostare la risoluzione a cui verrà creato l’oggetto immagine. 

Le immagini possono essere spostate, ridimensionate e ruotate, sia tramite gli strumenti di modifica, il pannello Info sull’oggetto o la finestra Impostazioni immagine.

Impostazioni dell’immagine 

La finestra Impostazioni immagine visualizza le seguenti opzioni per impostare le dimensioni sullo schermo, le dimensioni di stampa, la risoluzione e la trasparenza delle immagini: 

  • Dimensione: le dimensioni dell’oggetto immagine nel progetto, misurate in punti, millimetri, pollici o percentuale
  • Risoluzione dell’immagine, in punti per pollice.
  • Visualizza alla risoluzione dello schermo: quando è attivo, l’immagine viene sempre visualizzata alla risoluzione dello schermo, che è tipicamente inferiore a quella della carta. La dimensione visibile dell’immagine è più grande a risoluzioni inferiori.
  • Il pulsante Ripristina valori originali, per ripristinare le dimensioni e la risoluzione dell’immagine come nell’immagine sorgente
  • Trasparenza: imposta la quantità di trasparenza con cui l’immagine viene visualizzata. I valori vanno da 0%, totalmente opaco, a 100%, totalmente trasparente.
  • Formato file: le immagini sono gestite come altri oggetti vettoriali e salvate nel file del progetto. Il formato interno può essere PNG, che conserva la piena qualità dell’immagine, o JPEG, che comprime l’immagine e risparmia considerevolmente la dimensione del file, ma riduce la qualità. JPG è molto buono per le immagini fotografiche, ma non per le immagini che contengono disegni al tratto, come le mappe della città o i disegni scannerizzati.

I campi Dimensione immagine e Risoluzione permettono cambiamenti numerici. Si prega di notare che il rapporto Dimensione/Risoluzione è costante e quindi, quando si cambia la dimensione, la risoluzione cambierà di conseguenza e viceversa.

Usa il pulsante Info vicino all’Anteprima immagine per mostrare le informazioni dell’immagine sorgente sulla sua tela di anteprima. Le informazioni fornite sono: dimensione del file, date di creazione e modifica, posizione del file, dimensioni dell’immagine espresse in pixel e la sua risoluzione.

Quando il puntatore passa sopra l’Anteprima dell’immagine appare il pulsante “Sostituisci immagine”: cliccaci sopra per selezionare una nuova immagine sorgente da inserire nel riquadro dell’immagine esistente.


Gruppi

HighDesign fornisce la possibilità di raggruppare diversi oggetti come un unico elemento. La maggior parte delle operazioni di modifica e delle trasformazioni possono essere applicate solo agli elementi selezionati, sia ai singoli oggetti che a un gruppo di oggetti in una sola volta. 

I gruppi sono un modo conveniente di organizzare gli oggetti legando elementi eterogenei in una “collezione” che si comporta come un unico oggetto. Una volta che un certo numero di oggetti di disegno sono raggruppati insieme, puoi selezionarli semplicemente cliccando su uno qualsiasi dei membri del gruppo. Per default, gli oggetti raggruppati mantengono i loro attributi, come il colore, il tipo di linea, il peso, ecc. La modifica degli attributi di un gruppo applica le modifiche a tutti i suoi membri. 

Funzioni di gruppo del menu Progetto

Tutti i comandi collegati ai gruppi sono disponibili nel menu Progetto. Le funzioni per gestire i gruppi sono Group, Ungroup, Automatic Grouping, Ungroup All, Edit Group. 

  • Raggruppa crea un nuovo gruppo con tutti gli elementi attualmente selezionati.
  • Separa divide gli elementi nei gruppi selezionati.
  • Aggiungi al Gruppo include gli oggetti selezionati nel gruppo attualmente selezionato.
  • Raggruppamento automatico è un’opzione che crea automaticamente gruppi con oggetti di una forma, cioè rettangoli, poligoni regolari, polilinee, muri, ecc.
  • Separa tutti divide tutti i gruppi, inclusi quelli non selezionati.
  • Modifica gruppo apre un’area di lavoro dove è possibile modificare il gruppo selezionato modificando, aggiungendo o rimuovendo membri utilizzando i normali strumenti di disegno. 

Modificare un gruppo

Gli oggetti raggruppati possono essere modificati tutti insieme come un singolo oggetto di disegno allungando le maniglie del riquadro di delimitazione del gruppo con lo strumento Freccia. Un gruppo può essere spostato, ruotato, specchiato o scalato come qualsiasi altro oggetto.

  • Un gruppo può essere ridimensionato e spostato con lo strumento Freccia. Le proprietà applicate ad un gruppo vengono applicate a tutti i membri del gruppo.
  • Per selezionare i singoli membri di un gruppo, tenete premuto il tasto di comando e cliccate sull’oggetto. L’oggetto sarà selezionato e disponibile per essere modificato o cancellato. Questo metodo è più adatto per operazioni di modifica veloci. 
  • Potete anche modificare i membri di un gruppo attraverso il comando Edit Group.

L’area di lavoro Modifica gruppo

Puoi attivare l’area di lavoro Modifica gruppo selezionando un gruppo e cliccando l’icona Modifica sul punto di maniglia in alto a sinistra o scegliendo Progetto ▸ Modifica gruppo… Questo spazio di lavoro apre un pannello con comandi specifici che ti permettono di gestire i sottogruppi, mostrare o nascondere il contesto, aggiungere oggetti al gruppo o rimuovere oggetti da esso.

Se il gruppo include dei sottogruppi, puoi usare il menu Sottogruppi per attivare qualsiasi sottogruppo o tornare al gruppo principale. Per modificare un sottogruppo, clicca sull’icona Modifica sopra il suo angolo in alto a sinistra. Clicca su “Finito” per terminare la modifica.

Per impostazione predefinita, il gruppo modificato viene visualizzato all’interno del suo contesto, cioè gli oggetti circostanti del disegno in cui è inserito. È possibile regolare il livello di opacità del contesto o disabilitarlo del tutto.

Per aggiungere un oggetto esistente al gruppo, premi il pulsante Add Object nella sezione Actions e clicca su qualsiasi oggetto del contesto. Allo stesso modo, premi il pulsante Remove Object e clicca su qualsiasi oggetto del gruppo per rimuoverlo dal gruppo. L’oggetto rimosso verrà spostato nel foglio dove risiede il suo gruppo originale.

Si può anche disegnare qualsiasi classe di oggetti usando gli strumenti disponibili nella casella degli strumenti. Qualsiasi oggetto creato in questo modo sarà aggiunto al gruppo corrente.

Premi Finito per confermare le modifiche e tornare all’area di lavoro normale, o premi Cancel per respingere tutte le modifiche fatte nell’area di lavoro Modifica Gruppo.

Was this article helpful to you? Yes No

How can we help?