1. Home
  2. Docs
  3. Italiano: Aiuto e Documentazione
  4. Guida Avvio Rapido
  5. L’interfaccia di HighDesign

L’interfaccia di HighDesign

Conoscere gli elementi dell’interfaccia utente di HighDesign.

Finestra di Benvenuto

La finestra Benvenuti si apre per default quando lanciate HighDesign e presenta le opzioni per creare o aprire un progetto, aprire un documento recente, scegliere un modello per un nuovo progetto o aprire un esempio.

  • Sul lato destro della finestra puoi usare i collegamenti rapidi per accedere alla finestra Resource Manager, alla finestra Application Preferences e alla finestra Project Settings. Il pulsante “What’s New” apre la pagina web delle note di rilascio della versione corrente nel tuo browser predefinito.
  • Il pulsante “Visita guidata” avvia un breve tutorial che descrive ed evidenzia le diverse aree della finestra del progetto: una finestra popover spiega le funzioni corrispondenti di ogni area. Usa i pulsanti “Avanti” e “Indietro” della finestra popover o le frecce della tastiera per navigare attraverso i diversi elementi della finestra principale.
  • Quando lanciate HighDesign dopo che il programma non si è chiuso correttamente, la finestra di benvenuto si apre con un pannello aggiuntivo “Recovery” che elenca i file salvati automaticamente. Usate questo pannello per selezionare i file che volete aprire. Una volta che un file recuperato è stato aperto, viene rimosso dall’elenco. Durante la sessione corrente, è possibile accedere al pannello di recupero in qualsiasi momento aprendo la finestra Welcome dal menu Help.

Finestra del Progetto

  • L’area di disegno al centro della finestra del progetto visualizza le viste del progetto.
  • Le barre degli strumenti forniscono funzioni essenziali, come gli strumenti e i metodi di disegno, i campi di input e i comandi, le funzioni di modifica e i controlli delle proprietà. Attraverso questi comandi, disposti in aree logiche, tutte le funzioni di disegno sono facilmente accessibili.
  • La Sidebar fornisce funzioni che sono principalmente utilizzate per organizzare il progetto e gestire gli elementi del progetto: il Project Browser e i pannelli Views, Object Info e Graphic Attributes, e i pannelli Project Styles.
  • La barra dei menu nella parte superiore della finestra del progetto mostra i menu che elencano quasi tutte le funzioni, i comandi e le caratteristiche del programma.

Toolbox

Il Toolbox di HighDesign fornisce un facile accesso a tutti gli strumenti necessari per costruire il vostro modello e documentare i vostri disegni. È organizzato in quattro gruppi principali definiti dal loro scopo: Select, Sketch, Document e Design.

Le icone nella toolbox possono essere disposte su una o due colonne cliccando sull’icona di ridimensionamento sul lato inferiore della casella degli strumenti.

Usare i pulsanti

Usa gli strumenti della casella degli strumenti per disegnare linee, cerchi, forme, inserire testi, dimensioni, immagini, ecc. Uno strumento può avere più metodi, ognuno con la propria sequenza di passi e input richiesti per costruire un oggetto specifico.

Per esempio lo strumento Archi e Cerchi include i metodi per creare archi circolari per centro e raggio, per diametro, per due punti e raggio, per tre punti per tangenti; ellissi per raggi, per casella e quarto di ellisse.

  • Clicca su qualsiasi pulsante per attivare lo strumento.
  • Fare clic sulla freccia per aprire l’elenco a comparsa dei metodi dello strumento.

Alcune icone di strumenti mostrano tre punti nell’angolo in basso a destra: ciò significa che lo strumento offre proprietà più avanzate necessarie per costruire l’oggetto. Questo è tipicamente usato per oggetti più complessi come simboli, tratteggi, testi o dimensioni.

  • Fare doppio clic sullo strumento per aprire la sua finestra Tool Settings.

In HighDesign Pro, potete anche cliccare con il tasto destro del mouse sull’icona di uno strumento per aprire il pannello Stili. Questo pannello mostra gli stili o tipi disponibili per lo strumento cliccato.

  • Fare clic con il tasto destro del mouse (o ctrl-clic) su un’icona dello strumento per aprire il pannello degli stili e selezionare uno stile.
Fare clic con il tasto destro del mouse su uno strumento per selezionare uno stile

La barra delle proprietà

La barra delle proprietà è divisa in due aree:

La prima area mostra i metodi dello strumento corrente, espanso per mostrare tutte le icone su una riga quando c’è abbastanza spazio, o compresso ad una singola icona e menu a discesa.
Alcuni metodi richiedono parametri aggiuntivi, come il numero di lati di un poligono o il lato iniziale di un muro. Il controllo delle opzioni è visibile dopo le icone dei metodi.

  • La seconda area mostra le proprietà più comuni: lucido, colore della penna, riempimento, tipo di linea, marcatori di inizio e fine, dimensione della penna e il pulsante delle impostazioni che apre la finestra delle impostazioni dello strumento corrente, quando disponibile. Se uno o più oggetti sono attualmente selezionati, la modifica di una proprietà modifica tutti gli oggetti selezionati. Se non c’è selezione, la barra delle proprietà mostra e modifica le proprietà predefinite correnti che vengono applicate ai nuovi oggetti.

Ogni pulsante apre il proprio menu o pannello, con opzioni e comandi specifici per quella proprietà.

Strumenti di modifica

La barra di modifica mostra gli strumenti di modifica più comunemente usati. È divisa in tre gruppi: Trasformazioni, Modifiche di linea, Modifiche di forma.
Solo alcuni degli strumenti di modifica sono mostrati nella barra di modifica. Altri strumenti più specializzati possono essere trovati nel menu Strumenti.

Clicca su un’icona per attivare lo strumento. Se l’icona è disattivata, devi prima selezionare uno o più oggetti. Clicca di nuovo per annullare.
Per impostazione predefinita, le istruzioni passo-passo per utilizzare lo strumento sono visibili sulla barra di stato, nella parte inferiore della finestra.
Alcuni strumenti, come Multiply o Rotate by Angle, aprono un pannello fluttuante che permette la definizione di alcuni parametri. Queste finestre rimangono aperte mentre lo strumento è attivo e vi si può accedere in qualsiasi momento durante i passi dell’operazione di modifica.

  • Gli strumenti di Trasformazione danno accesso alle funzioni che applicano trasformazioni geometriche agli oggetti: Sposta, Duplica, Moltiplica lineare e polare; Rotazione libera e Rotazione per angolo; Specchio e Specchio & Duplica; Stiramento; Ridimensionamento. La maggior parte di questi strumenti sono abilitati solo quando un oggetto compatibile è selezionato.
  • Gli strumenti di Modifiche Lineari includono funzioni che si applicano agli oggetti lineari: Trova intersezione, Unisci, Estendi, Dividi, Taglia, Dividi in parti e Rompi.
  • Gli strumenti Modifica Forma applicano modifiche più complesse che modificano la forma dell’oggetto e aggiungono o rimuovono elementi, come Fillet e Chamfer, Offset, Extrude, Explode, ecc.

Barra di inserimento, pulsanti di opzione e barra di stato

La parte inferiore della finestra principale ospita il gruppo di barre degli strumenti che ti permettono di controllare gli snap e i vincoli del disegno, impostare la scala e le unità del disegno corrente, inserire coordinate e valori e cambiare il fattore di zoom e altre opzioni di visualizzazione.

Mentre è possibile controllare queste opzioni da altri pannelli e menu altrove, questi pulsanti sono sempre disponibili qui per un facile accesso e revisione.

Barra laterale e pannelli

Il lato della finestra principale contiene la Sidebar dove i pannelli di utilità sono facilmente accessibili e organizzati in gruppi. La barra laterale riempie il lato dell’area di disegno e può essere ridimensionata per mostrare più contenuto.

In HighDesign SE e HighDesign Pro, è possibile riordinare i pannelli della barra laterale trascinandoli in un nuovo gruppo, ridimensionare i gruppi e trascinare i pannelli fuori dalla barra laterale e aprirli come finestre fluttuanti.

La barra laterale può essere ridotta a una barra verticale di schede, in modo da non occupare spazio sullo schermo quando i pannelli non sono in uso. Clicca su una scheda per aprire il pannello come finestra pop-up e clicca fuori per chiuderlo.

Puoi anche aprire e chiudere i pannelli dal menu Finestra > Pannelli.

I pannelli forniscono l’accesso alle funzioni più utilizzate: navigare tra gli elementi del progetto, attivare e disattivare i livelli, memorizzare e attivare le viste del progetto, visualizzare e modificare le proprietà geometriche e grafiche della selezione.

Tipicamente, un pannello non replica tutte le caratteristiche disponibili per la sua funzione, in modo da mantenere il suo uso veloce e diretto. Quelle funzioni che forniscono opzioni più avanzate, come i livelli o gli stili, un pulsante apre il gestore delle funzioni dove è possibile effettuare ulteriori regolazioni e personalizzazioni.

Was this article helpful to you? Yes No

How can we help?