1. Home
  2. Docs
  3. Italiano: Aiuto e Documentazione
  4. Guida Utente
  5. 9. Tecniche Fondamentali

9. Tecniche Fondamentali

Tecniche di disegno di base
Argomenti in questa sezione

Snap e allineamenti

Lo snapping è una funzione che permette il posizionamento preciso di oggetti e punti di inserimento facendo sì che alcuni punti dell’area di disegno o parti di oggetti attirino il cursore. Si comporta come una proprietà magnetica che regola la posizione del cursore quando si trova entro un certo intervallo. HighDesign fornisce uno snap automatico ai nodi della griglia, al corpo dell’oggetto, al vertice, all’intersezione, all’angolo retto / tangente e agli allineamenti.
Gli snap possono essere attivati e disattivati attraverso il menu Snaps in basso a sinistra della finestra principale nella Input Bar. Le opzioni di snap possono anche essere visualizzate come una comoda finestra fluttuante disponibile tramite il menu Finestra.

Tipi di Snap 

La funzione Snap è sempre evidenziata da una forma diversa del puntatore e contrassegnata da una maniglia sullo schermo che corrisponde alla condizione di snap corrente. A seconda delle preferenze correnti, il tipo di scatto può anche essere evidenziato da un’etichetta sullo schermo e da un suono.

Le opzioni di scatto disponibili corrispondono ai seguenti tipi di scatto:

  • Snap to grid: il puntatore scatta alle intersezioni della griglia e alle sue sotto-divisioni; 
  • Snap to endpoint o vertice; 
  • Snap to object: il puntatore riconosce una distanza minima dal corpo di un oggetto; 
  • Snap to intersection: tutte le intersezioni sono interpretate come punti finali; 
  • Snap to right-angle: il puntatore cambia quando il segmento corrente ne interseca un altro con un angolo retto; 
  • Snap to tangent: il puntatore cambia quando la linea corrente è tangente a un cerchio / arco; 
  • Snap to alignments: il puntatore si aggancia a due guide temporanee; 
  • Snap to Sub-Objects: permette lo snap agli oggetti all’interno delle istanze dei simboli inseriti nel progetto e all’interno delle Viewport inserite nei Layout. 

Allineamenti

Quando il puntatore scatta su un punto finale di un oggetto, quella posizione viene memorizzata come origine corrente delle guide temporanee; le guide vengono visualizzate quando il cursore si trova sull’asse X o Y di quel punto di riferimento. 

Il puntatore scatta anche all’intersezione delle guide: l’intersezione è evidenziata con un punto ed entrambe le guide visibili.

Inoltre, quando si posiziona il puntatore su un segmento, questa funzione memorizza l’angolo di quel segmento visualizzando le guide parallele e ortogonali corrispondenti: quando si traccia la linea, basta posizionare il puntatore su un punto di riferimento di quel segmento (punti finali o punto medio) per visualizzare l’allineamento. 

Per disabilitare temporaneamente lo Snap to alignments, tieni premuto il tasto “cmd” (Mac) o “ctrl” (Windows).


Vincoli geometrici

Le funzioni di Vincolo di disegno vi permettono di disegnare rapidamente degli oggetti con alcune condizioni, come il parallelismo, l’angolo definito o le intersezioni. I campi di input sulla barra di input permettono di inserire le coordinate dei punti di disegno e le dimensioni geometriche degli oggetti, come lunghezza e angolo. 

Direzioni vincolate 

Gli oggetti grafici lineari o poligonali come linee e polilinee, rettangoli ruotati, tratteggi, archi ed ellissi per raggio e diametro, dimensioni e pareti, possono essere disegnati allineati con uno degli assi cartesiani o ruotati per passi di 15 gradi: per fare questo, basta premere il tasto Shift mentre si muove il puntatore. 

Parallelo vincolato, ad angolo retto e allineato/tangente 

Questi tre pulsanti sulla barra di inserimento forniscono i vincoli Angolo retto e Parallelo e la condizione Intersecato. 

Vincolare il parallelo (P) e l’angolo retto (R) 

Queste condizioni possono essere attivate in qualsiasi momento con qualsiasi strumento o funzione di editing e influiranno sulla direzione del movimento corrente. 

Per attivare la condizione di angolo retto o parallelo: 

  1. Dopo il primo clic dell’operazione corrente che state eseguendo, cliccate il pulsante corrispondente alla condizione desiderata o premete il suo equivalente da tastiera (P o R); 
  2. Cliccate sull’oggetto di riferimento, per esempio la linea che volete disegnare perpendicolare o parallela (il cursore del mouse si trasforma in una mano che punta quando si trova su un oggetto valido); 
  3. Per annullare una condizione, premere il tasto Esc sulla tastiera. 

Vincolo Allineato/Tangente 

Questa condizione vincola il puntatore a intersecare una linea o un cerchio di riferimento, estendendo la linea che state disegnando al punto di intersezione, anche al di fuori dei limiti del segmento, o vincolando la direzione alla tangente. 

Per attivare questa condizione, cliccate il pulsante nella barra di inserimento o premete il suo equivalente da tastiera. Se la condizione è attivata prima che il punto di partenza sia definito, vincola il punto di partenza ad essere allineato alla retta o alla tangente al cerchio. Se attivata dopo il primo clic, vincola il punto finale. 

Lo stesso risultato può essere ottenuto premendo il tasto Cmd + clic sulla linea di riferimento mentre si disegna la linea, il poligono, il muro o il tratteggio/riempimento. 

L’opzione Vincola Tangente può essere attivata per costruire una linea tangente a un arco o a un cerchio, sia dal punto iniziale che dal punto finale. 

Per costruire una linea tangente a un arco o a un cerchio dal punto di partenza: 

  • Attivare l’opzione Constrain Tangent.
  • Cliccate sull’arco o sul cerchio di riferimento. Spostando il puntatore, il punto di partenza del segmento manterrà la condizione di tangente più vicina al punto cliccato.

Costruire una linea tangente a un arco o a un cerchio sul punto finale: 

  1. Clicca per definire il punto di partenza della linea. 
  2. Attivare l’opzione Constrain Tangent. 
  3. Clicca sull’arco o sul cerchio di riferimento. 

I vincoli di disegno e le opzioni di snap possono anche essere visualizzati come raggruppati in una finestra fluttuante che puoi spostare in una posizione conveniente sullo schermo. Per mostrare questa opzione, seleziona “Snaps” nel menu Finestra. 


Coordinate, distanze e angoli

I campi di input sono raggruppati al centro della barra di input: usate questi campi per inserire i valori delle coordinate vincolate, la lunghezza e l’angolo dell’oggetto che state disegnando. I campi X, Y e L supportano anche l’aggiunta di valori parziali. 

Quando si clicca su un campo o si usa la scorciatoia da tastiera, appare un aiuto visivo per indicare il vincolo corrente. 

In tutti i campi di input, i valori possono essere inseriti sia come numeri, come “100”, sia come somma di numeri, come “100+20+60”. 

Coordinate X e Y 

Le coordinate in HighDesign sono assolute o relative. Le coordinate assolute sono calcolate dal punto di origine globale del disegno, e le coordinate relative sono calcolate dal punto precedente dell’oggetto. 

Il punto di inserimento di un oggetto, cioè il suo punto di partenza, è sempre impostato e visto in coordinate assolute, con i valori X e Y calcolati dall’origine del foglio corrente. Il punto successivo è relativo per impostazione predefinita, ma è possibile cambiarlo da relativo ad assoluto cliccando l’icona X o Y sul campo di inserimento. 

Per esempio, in una linea con punti a (20, 20) e (100, 100), il punto finale è (100, 100) in coordinate assolute e (80, 80) in coordinate relative. 

Per impostare il punto di inserimento assoluto:  

  1. Cliccate sul campo di inserimento corrispondente o premete i tasti “X” o “Y” della tastiera; 
  2. Inserisci la distanza X o Y desiderata dall’Origine;
  3. Premere Return per confermare. 

Per impostare il punto finale relativo:  

  1. Clicca sui campi delle coordinate o premi i tasti “X” o “Y” sulla tastiera; 
  2. Inserisci la distanza dx o dy desiderata dal punto di partenza;
  3. Premere Return per confermare. 

Si può passare dalle coordinate relative a quelle assolute e viceversa cliccando l’icona X o Y sul campo di input o usando le scorciatoie da tastiera corrispondenti. 

Lunghezza vincolata  

Potete vincolare un segmento, una linea o un raggio ad una lunghezza fissa dopo aver impostato il punto di partenza. In HighDesign, ci sono due metodi per vincolare una lunghezza che possono essere usati in modo intercambiabile. 

A. Definire la direzione, impostare la lunghezza. 

  1. Dopo aver impostato il punto di inserimento, spostare il puntatore sull’angolo desiderato del punto successivo; 
  2. Inserire la lunghezza desiderata, come lunghezza totale o come somma di valori parziali; 
  3. Premere Return per confermare; 

B. Definire la lunghezza, impostare la direzione. 

  1. Clicca sul campo Lunghezza o premi il tasto “L” sulla tastiera; 
  2. Inserisci la lunghezza desiderata; 
  3. Premere Return per confermare; 
  4. Spostare il puntatore per impostare l’angolo del vettore. 

Angolo vincolato 

Per vincolare il movimento del puntatore a un angolo fisso: 

  1. Cliccate sul campo “A” (Angle) o premete il tasto “A” sulla tastiera; 
  2. Inserire il valore dell’angolo desiderato (in gradi); 
  3. Premere Return per confermare; 
  4. Spostare il puntatore per impostare la lunghezza desiderata. 

Angolo relativo 

È possibile vincolare il puntatore a un angolo relativo a una direzione di riferimento: 

  1. Cliccate sul campo “A” o premete il tasto “A” sulla tastiera; 
  2. Inserire il valore dell’angolo desiderato (non premere il tasto “Enter”); 
  3. Cliccare sulla direzione di riferimento (linea, segmento di polilinea o muro); 
  4. Spostare il puntatore per impostare la lunghezza della destinazione. 

Distanza vincolata  

Per impostare la distanza del punto di inserimento/inizio di un oggetto da un punto di origine, digitate il valore, premete Invio e cliccate sul punto di origine; la distanza viene ora visualizzata come un raggio dal punto di origine: cliccate per impostare il punto di inserimento/inizio dell’oggetto.

Attivare i vincoli di disegno usando il tasto TAB 

I vincoli di disegno per le coordinate X e Y, la lunghezza e l’angolo possono essere attivati anche premendo il tasto Tab sulla tastiera. Quando si preme quel tasto per la prima volta si attiva il vincolo X; poi, nell’ordine, Y, L, A. L’attivazione del vincolo Y memorizza qualsiasi valore inserito nel campo X, in modo da facilitare l’impostazione delle coordinate di un punto.


Zoom e panoramica

Questi strumenti di visualizzazione, di default raggruppati in un comodo dock sul bordo dell’area di disegno, sono essenziali per gestire i disegni. La prima volta che lanci HighDesign Panning, Zoom e Zoom to fit sono agganciati come pulsanti semitrasparenti nell’angolo in alto a destra dell’area di disegno: cliccando con il tasto destro del mouse sul dock puoi aprire un menu con le opzioni per cambiare la posizione del dock.

Inoltre, nella sezione Zoom e scorrimento del pannello Workspace di HighDesign Preferences puoi aprire il menu “View controls” per cambiare la posizione del dock o per visualizzare i controlli nella barra degli strumenti principale.

Pan

Usate questo strumento per trascinare l’area di disegno e spostare rapidamente la vista corrente. Per usare lo strumento Panning cliccate e trascinate il puntatore del mouse.
Fate doppio clic sull’icona dello strumento per impostare la vista al centro del disegno. 

Lo strumento di panoramica può anche essere attivato temporaneamente con qualsiasi strumento premendo la barra spaziatrice sulla tastiera: se avete già iniziato un compito, per esempio disegnare una linea, l’uso dello strumento di panoramica non interferirà con la funzione corrente. 

Con un mouse a più pulsanti è possibile fare una panoramica del disegno cliccando il pulsante centrale/ruota e trascinando il puntatore. 

Zoom

Lo strumento Zoom permette di ingrandire o ridurre la vista corrente del disegno ingrandendo o riducendo. 

Clicca sul punto di partenza, poi sposta il puntatore e clicca di nuovo per definire l’area rettangolare che sarà ingrandita. Tieni premuto il tasto Opzione per ridurre lo zoom. 

Il fattore di zoom è inversamente proporzionale alla dimensione del rettangolo di zoom, cioè, più piccolo è il rettangolo, più alto sarà il fattore. 

Fate doppio clic sull’icona dello strumento per riportare il fattore di vista al 100% (vista reale). 

Altri comandi di zoom sono raggruppati sotto il menu View, incluso “Zoom to Fit”, “Zoom In” e “Zoom Out”. 

Lo zoom dinamico si attiva premendo i pulsanti “cmd e +” o “cmd e -” sulla tastiera o, con un mouse a più pulsanti, ruotando la rotella: ruotate la rotella in avanti per ingrandire e all’indietro per ridurre. Anche i gesti del trackpad sono supportati dallo zoom dinamico. 

Zoom all’ingombro

Questo controllo di utilità di visualizzazione è anche disponibile come un pulsante nel dock degli strumenti di visualizzazione: cliccando questo pulsante il fattore di zoom e il centro della vista sono regolati per adattarsi all’estensione dell’area di disegno. In questo modo si ottiene una vista panoramica di tutto il disegno visibile.

Quando uno o più oggetti sono selezionati, questo controllo centra solo la vista della selezione.

Was this article helpful to you? Yes No

How can we help?