1. Home
  2. Docs
  3. Italiano: Aiuto e Documentazione
  4. Guida Utente
  5. 7. Importare e Esportare

7. Importare e Esportare

Condividere il tuo progetto
Argomenti in questa sezione

Importazione di disegni DWG/DXF

Selezionare File ▸ Importa ▸ File DXF/DWG singolo. Prima di aprire un file DXF/DWG una finestra di dialogo permette di impostare le impostazioni di base per l’importazione: 

  • Unità di disegno da usare per convertire gli elementi DXF/DWG; la maggior parte delle versioni DXF/DWG non include un’unità di misura;
  • Scala di destinazione del disegno;
  • Quando l’opzione “Use file drawings units” è attiva, HighDesign cerca di impostare le unità di disegno come si trovano nel file. Se non viene trovata nessuna unità di disegno questa opzione non ha effetto;
  • Opzioni per impostare il colore di sfondo al nero o per aggiungere un prefisso ai livelli;

HighDesign SE e Pro importano documenti DWG/DXF con entrambi i dati Layout e Modello: quando si apre il documento, il disegno, o Modello, si trova sul foglio chiamato “Modello”. In HighDesign SE, i fogli di layout sono importati come fogli di disegno con un formato carta definito; in HighDesign Pro, gli oggetti Layout sono importati in fogli di layout.

HighDesign Lt importa solo lo spazio modello. I layout sono ignorati.

Inserire un disegno DWG/DXF (SE e Pro)

In HighDesign SE e Pro, utilizzare la voce di menu Progetto ▸ Inserisci ▸ Disegno DWG/DXF per inserire un disegno DWG/DXF nel progetto corrente senza creare un nuovo documento. Questo comando aggiungerà un nuovo foglio di disegno con lo spazio modello del disegno specificato.

Importazione di blocchi DWG/DXF (Pro)

Usate il comando “Importa blocchi DWG/DXF” per convertire una cartella di blocchi o disegni DXF/DWG in simboli nativi di HighDesign. La conversione di una libreria di simboli è un processo in due fasi, tutto eseguito in una singola finestra. 

Scegliere File ▸ Importa ▸ Importa Blocchi DWG/DXF…; si apre la seguente finestra:  

  • Opzioni di conversione – convertire blocchi/disegni in una cartella o blocchi in un file DWG/DXF. Premi il pulsante Scegli 
  • Quando il processo di importazione è completo, puoi usare la tabella per rivedere e modificare i simboli importati. 
  • Anteprima del simbolo.
  • Cliccare il pulsante Converti per salvare i simboli di HighDesign nella cartella corrente della Libreria. 

La lista dei simboli può essere riordinata trascinando le righe. 

Il primo passo consiste nel selezionare la cartella sul vostro disco e importare tutti i disegni leggibili contenuti in essa. I formati supportati sono tutte le versioni DXF dalla R10 alla 2020 e tutte le versioni DWG dalla R9 alla 2020 (il supporto DWG è disponibile solo in HighDesign Standard e Pro). 

Premere il pulsante Import per scegliere la cartella. Se la cartella selezionata contiene file leggibili, si apre la finestra di dialogo standard di importazione DXF/DWG che permette di impostare le opzioni di scala e unità di disegno. 

Con il secondo passo potete impostare le opzioni e completare la conversione in simboli di HighDesign. La tabella mostra il nome, la scala, la larghezza, l’altezza e l’anteprima di ogni simbolo, permettendovi di modificare gli attributi del simbolo prima che venga salvato.

Estendere la libreria di simboli predefinita 

È possibile estendere la vostra libreria di simboli creando nuovi simboli personalizzati o aggiungendo librerie esterne: il comando “Add Symbol Library” nel menu File vi permette di selezionare una cartella di simboli di HighDesign e copiarli nella cartella desiderata nella cartella User Library. 

Esportare il tuo progetto

Il tuo progetto può essere esportato in molti formati grafici. Seleziona File ▸ Esporta come e scegli il formato del file di destinazione: 

  • DWG dalla versione R12 alla 2018-2020 (.dwg). 
  • DXFt dalla versione R12 alla 2018-2020 (.dxf). 
  • DXB (.dxb) versioni R12-2018-2020. 
  • PDF vettoriale (.pdf) – (Pro). 
  • TIFF (.tif). 
  • JPEG (.jpg). Quando si esporta un disegno in JPEG, una finestra di dialogo permette di impostare la qualità di compressione e gli attributi specifici del JPEG. Nella metà destra di questa finestra di dialogo, un’anteprima mostra il nuovo file e l’immagine originale.
  • PNG (.png). PNG supporta alti DPI e fornisce l’opzione di esportare con il canale Alpha. I canali alfa sono maschere a 8 bit che rendono l’immagine finale trasparente. In HighDesign, un PNG con canale alfa è un’immagine trasparente senza sfondo. 
  • GIF (.gif).
  • BMP (Windows Bitmap).

La finestra di dialogo Esporta come DWG/DXF fornisce le seguenti opzioni:  

  • Formato versione tramite un menu a comparsa. Disponibile anche in HighDesign Standard; 
  • Elenco dei fogli del progetto HighDesign e possibilità di selezionare fogli di disegno, dettagli e layout da esportare; 
  • Opzione per esportare tutti i fogli selezionati come un unico documento DWG/DXF; 
  • Opzione per esportare ogni foglio selezionato come documento separato (tutti i documenti sono raccolti in una cartella). 
Was this article helpful to you? Yes No

How can we help?