1. Home
  2. Docs
  3. Français : Aide et documentation
  4. Guide de démarrage rapide
  5. L’interface de HighDesign

L’interface de HighDesign

Apprenez à connaître les éléments de l’interface utilisateur de HighDesign.

Fenêtre de bienvenue

La fenêtre de bienvenue s’ouvre par défaut lorsque vous lancez HighDesign et présente les options suivantes : créer ou ouvrir un projet, ouvrir un document récent, choisir un modèle pour un nouveau projet ou ouvrir un exemple.

  • Sur le côté droit de la fenêtre, vous pouvez utiliser les liens rapides pour accéder à la fenêtre du gestionnaire de ressources, à la fenêtre des préférences de l’application et à la fenêtre des paramètres du projet. Le bouton “Quoi de neuf” ouvre la page web des notes de version de la version actuelle dans votre navigateur par défaut.
  • Le bouton “Visite guidée” lance un court tutoriel qui décrit et met en évidence les différentes zones de la fenêtre du projet : une fenêtre popover explique les fonctions correspondantes de chaque zone. Utilisez les boutons “Suivant” et “Précédent” de la fenêtre popover ou les flèches du clavier pour parcourir les différents éléments de la fenêtre principale.
  • Lorsque vous lancez HighDesign après que le programme ne s’est pas fermé correctement, la fenêtre de bienvenue s’ouvre avec un panneau supplémentaire “Recovery” listant les fichiers sauvegardés automatiquement. Utilisez ce panneau pour sélectionner les fichiers que vous souhaitez ouvrir. Une fois qu’un fichier récupéré a été ouvert, il est supprimé de la liste. Pendant la session en cours, vous pouvez accéder au panneau de récupération à tout moment en ouvrant la fenêtre de bienvenue à partir du menu Aide.

Fenêtre du projet

  • La zone de dessin au milieu de la fenêtre de projet affiche les vues du projet.
  • Les barres d’outils fournissent des fonctions essentielles, telles que les outils et méthodes de dessin, les champs de saisie et les commandes, les fonctions d’édition et les contrôles de propriétés. Grâce à ces commandes, disposées dans des zones logiques, toutes les fonctions de dessin sont facilement accessibles.
  • La barre latérale fournit des fonctions qui sont principalement utilisées pour organiser le projet et gérer les éléments du projet : le navigateur de projet et les panneaux Vues, Info objet et Attributs graphiques, et les panneaux Styles de projet.
  • La barre de menu située en haut de la fenêtre du projet affiche les menus répertoriant presque toutes les fonctions, commandes et caractéristiques du programme.

Boîte à outils

La boîte à outils HighDesign permet d’accéder facilement à tous les outils dont vous avez besoin pour construire votre modèle et documenter vos dessins. Elle est organisée en quatre groupes principaux définis par leur objectif : Select, Sketch, Document et Design.

Les icônes de la boîte à outils peuvent être disposées sur une ou deux colonnes en cliquant sur l’icône de redimensionnement située dans la partie inférieure de la boîte à outils.

Utilisation des boutons

Utilisez les outils de la boîte à outils pour tracer des lignes, des cercles, des formes, insérer des textes, des dimensions, des images, etc. Un outil peut avoir plusieurs méthodes, chacune ayant sa propre séquence d’étapes et d’entrées requises pour construire un objet spécifique.

Par exemple, l’outil Arcs et ovales comprend les méthodes permettant de créer des arcs de cercle par centre et rayon, par diamètre, par deux points et rayon, par trois points et tangentes ; des ellipses par rayons, par boîte et quart d’ellipse.

  • Cliquez sur un bouton pour activer l’outil.
  • Cliquez sur la flèche pour ouvrir la liste contextuelle des méthodes de l’outil.

Certaines icônes d’outils affichent trois points dans le coin inférieur droit : cela signifie que l’outil offre des propriétés plus avancées nécessaires à la construction de l’objet. Cela est généralement utilisé pour les objets plus complexes comme les symboles, les hachures, les textes ou les dimensions.

  • Double-cliquez sur l’outil pour ouvrir sa fenêtre Paramètres de l’outil.

Dans HighDesign Pro, vous pouvez également cliquer avec le bouton droit de la souris sur l’icône d’un outil pour ouvrir le panneau Styles. Ce panneau affiche les styles ou types disponibles pour l’outil cliqué.

  • Cliquez avec le bouton droit de la souris (ou ctrl-clic) sur une icône d’outil pour ouvrir le panneau Styles et sélectionnez un style.
Cliquez avec le bouton droit de la souris sur un outil pour sélectionner un style

La barre de propriétés

La barre de propriétés est divisée en deux zones :

  • La première zone présente les méthodes de l’outil en cours, étendues pour afficher toutes les icônes sur une ligne lorsqu’il y a suffisamment d’espace, ou compressées en une seule icône et un menu déroulant.
    • Certaines méthodes nécessitent des paramètres supplémentaires, comme le nombre de côtés d’un polygone ou le côté avant d’un mur. La commande d’option est visible après les icônes de méthode.
  • La deuxième zone affiche les propriétés les plus courantes : couche, couleur du stylo, remplissage, type de ligne, marqueurs de début et de fin, taille du stylo, et le bouton de paramétrage qui ouvre la fenêtre Paramètres de l’outil en cours, lorsqu’il est disponible. Si un ou plusieurs objets sont actuellement sélectionnés, le changement d’une propriété modifie tous les objets sélectionnés. S’il n’y a pas de sélection, la barre de propriétés affiche et modifie les propriétés par défaut actuelles qui sont appliquées aux nouveaux objets.

Chaque bouton ouvre son propre menu ou panneau, avec des options et des commandes spécifiques à cette propriété.

Outils d’édition

La barre d’édition présente les outils d’édition les plus couramment utilisés. Elle est divisée en trois groupes : Transformations, Edition de lignes, Modifications de formes.
Seuls certains des outils d’édition sont affichés dans la barre d’édition. D’autres outils plus spécialisés se trouvent dans le menu Outils.

  • Cliquez sur une icône pour activer l’outil. Si l’icône est désactivée, vous devez d’abord sélectionner un ou plusieurs objets. Cliquez à nouveau pour annuler.
    • Par défaut, les instructions étape par étape pour utiliser l’outil sont visibles dans la barre d’état, en bas de la fenêtre.
    • Certains outils, comme Multiplier ou Faire pivoter par angle, ouvrent un panneau flottant qui permet de définir certains paramètres. Ces fenêtres restent ouvertes tant que l’outil est actif et peuvent être consultées à tout moment pendant les étapes de l’opération d’édition.
  • Les outils de transformation donnent accès aux fonctions qui appliquent des transformations géométriques aux objets : Déplacement, Duplication, Multiplication linéaire et polaire ; Rotation libre et Rotation par angle ; Miroir et Miroir et Duplication ; Étirement ; Redimensionnement. La plupart de ces outils ne sont activés que lorsqu’un objet compatible est sélectionné.
  • Les outils d’édition de lignes comprennent des fonctions qui s’appliquent aux objets linéaires : Trouver l’intersection, Joindre, Étendre, Diviser, Découper, Diviser en parties et Rompre.
  • Les outils de modification de forme appliquent des éditions plus complexes qui modifient la forme de l’objet et ajoutent ou suppriment des éléments, comme le congé et le chanfrein, le décalage, l’extrusion, l’explosion, etc.

Barre de saisie, boutons d’option et barre d’état

La partie inférieure de la fenêtre principale accueille le groupe de barres d’outils qui vous permettent de contrôler les accrochages et les contraintes de dessin, de définir l’échelle et les unités de dessin actuelles, de saisir des coordonnées et des valeurs, et de modifier le facteur de zoom et d’autres options d’affichage.

Bien que vous puissiez contrôler ces options à partir d’autres panneaux et menus ailleurs, ces boutons sont toujours disponibles ici pour un accès et un examen faciles.

Barre latérale et panneaux

Le côté de la fenêtre principale contient la barre latérale où les panneaux utilitaires sont facilement accessibles et organisés en groupes. La barre latérale remplit le côté de la zone de dessin et peut être redimensionnée pour afficher plus de contenu.

Dans HighDesign SE et HighDesign Pro, vous pouvez réorganiser vos panneaux de la barre latérale en les faisant glisser vers un nouveau groupe, redimensionner les groupes et faire glisser les panneaux hors de la barre latérale pour les ouvrir sous forme de fenêtres flottantes.

La barre latérale peut être réduite à une barre d’onglets verticale, de sorte qu’elle n’occupe pas d’espace à l’écran lorsque les volets ne sont pas utilisés. Cliquez sur un onglet pour ouvrir le panneau sous forme de fenêtre contextuelle et cliquez en dehors pour le fermer.

Vous pouvez également ouvrir et fermer des panneaux à partir du menu Fenêtre > Panneaux.

Les panneaux permettent d’accéder aux fonctionnalités les plus utilisées : naviguer parmi les éléments du projet, activer et désactiver les couches, stocker et activer les vues du projet, visualiser et modifier les propriétés géométriques et graphiques de la sélection.

En général, un panneau ne reproduit pas l’ensemble des fonctionnalités disponibles pour sa fonction, de manière à ce que son utilisation reste rapide et simple. Pour les fonctions qui offrent des options plus avancées, comme les calques ou les styles, un bouton ouvre le gestionnaire de fonctions où vous pouvez effectuer des ajustements et des personnalisations supplémentaires.

Was this article helpful to you? Yes No

How can we help?