1. Home
  2. Docs
  3. Français : Aide et documentation
  4. Guide d’utilisation de HighDesign
  5. 13. Outils de dessin

13. Outils de dessin

Créer des formes géométriques et des objets de base
Sujets dans cette section

Compétences de base en matière de dessin

Le processus de base pour dessiner un objet dans HighDesign consiste à sélectionner l’outil souhaité, à choisir une méthode de dessin parmi celles disponibles dans l’outil et à cliquer sur la zone de dessin pour commencer la construction de l’objet. S’il y a des objets sélectionnés, le premier clic désélectionne tout.

Les nouveaux objets sont créés en utilisant les attributs et propriétés graphiques par défaut actuels : calque, trait et remplissage, type de ligne, etc. Si l’objet créé est un élément, c’est-à-dire un objet plus complexe qu’une forme de base, comme les hachures ou les textes, vous pouvez définir les valeurs par défaut spécifiques via sa fenêtre Paramètres. Double-cliquez sur l’icône de l’outil dans la boîte à outils pour ouvrir la fenêtre des paramètres pour cette classe d’objets.

Les attributs et les propriétés peuvent également être modifiés à tout moment après la création de l’objet : sélectionnez l’objet et modifiez les propriétés souhaitées.

Techniques de dessin

  • La procédure de dessin par défaut adoptée dans HighDesign est “Cliquer-Déplacer-Cliquer”, c’est-à-dire que pour tracer une ligne, vous cliquez pour définir le point de départ, vous déplacez le pointeur à l’endroit souhaité et vous cliquez à nouveau pour définir son point d’arrivée. Le cliquer-glisser est également pris en charge. Vous pouvez modifier la méthode de dessin dans Préférences ▸ Dessin. 
  • Certains outils, comme l’outil Polygone, nécessitent un double-clic pour définir le point final. 
  • Pour annuler une opération, vous pouvez appuyer sur la touche “Esc” du clavier ou sur le bouton droit de la souris. 

Les objets multi-segments, tels que les polylignes, les hachures, les chemins, suivent la même méthode générale : cliquez pour définir les sommets, double-cliquez ou appuyez sur la touche Echap pour terminer.

Les procédures générales de rédaction décrites ci-dessus sont également valables pour les outils de rédaction, de documentation et de conception.


Sélection

L’outil Flèche vous permet de sélectionner les objets du dessin en cliquant directement sur eux ou en définissant une zone de sélection. Pour sélectionner un objet, cliquez dessus avec l’outil flèche. La fonction Snap to Objects doit être active pour que l’outil flèche puisse ” voir ” l’objet sur lequel vous cliquez. 

Méthodes

Sélection rectangulaire

Cliquez sur une partie vide de l’écran et déplacez le pointeur pour définir un rectangle : les objets dont les points de contrôle se trouvent à l’intérieur du rectangle seront sélectionnés. 
Si vous vous déplacez du haut vers le bas, la sélection comprendra tous les objets partiellement ou totalement fermés (sélection inclusive) ; si vous vous déplacez du bas vers le haut, la sélection comprendra uniquement les objets totalement fermés (sélection exclusive). Vous pouvez inverser le mode de sélection à tout moment en maintenant la touche Alt (Option) enfoncée.

Modes de sélection inclusifs et exclusifs

Sélection polygonale

Utilisez cette méthode pour sélectionner des objets en définissant une région polygonale. Cliquez pour ajouter un sommet à la région de sélection, double-cliquez pour mettre fin à la sélection.

Ajout et suppression d’objets

Maintenez la touche Shift enfoncée tout en cliquant pour ajouter des éléments à la sélection ou supprimer des éléments déjà sélectionnés. Cliquez sur une partie vide de l’écran pour tout désélectionner. Si l’option “Les clics de l’outil fléché étendent la sélection” est active dans les Préférences, cliquer sur un objet non sélectionné l’ajoutera automatiquement à la sélection.

Sélection d’objets se chevauchant

Lorsque deux ou plusieurs éléments se chevauchent, il peut être difficile de sélectionner le bon objet. Pour obtenir une sélection intelligente, activez l’outil Flèche, maintenez la touche Contrôle enfoncée et cliquez ou cliquez avec le bouton droit de la souris sur l’intersection pour ouvrir un menu contextuel contenant une liste de tous les objets situés à cet endroit, de haut en bas.

Modification des objets

L’outil Flèche peut également être utilisé comme un outil d’édition polyvalent : la plupart des actions d’édition spécifiques à un outil, telles que le redimensionnement d’une ligne ou l’édition d’un texte, peuvent également être effectuées avec l’outil Flèche.

  • Si vous cliquez sur le contour d’un objet sélectionné, mais pas sur un sommet, vous activez la fonction Déplacement.
  • Cliquer sur un sommet d’un objet redimensionne l’objet.
  • Le survol du curseur sur un sommet d’une hachure, d’une polyligne ou d’une spline sélectionnée ouvre le menu des options permettant de modifier le sommet.
  • Maintenez la touche Commande enfoncée pour déplacer tout objet, sélectionné ou non, par l’un de ses sommets ou par son contour. 

Objets de Construction

L’outil Objets de construction peut être utilisé pour marquer des éléments de référence et des objets auxiliaires dans le dessin. Il possède trois modes : point, pour créer des points de référence dans le dessin ; ligne de construction, pour ajouter des lignes infinies pour les alignements et les marges ; origine, pour définir l’origine du système de coordonnées dans le dessin actuel. 

Méthodes 

Points de référence

Cliquez sur l’emplacement souhaité pour insérer un point ou appuyez sur les touches X et Y du clavier pour entrer ses coordonnées. Dans la fenêtre Imprimer, vous pouvez choisir d’imprimer les points de référence et les lignes de construction.

Ligne de construction/guide

Cette méthode vous permet de créer des guides, c’est-à-dire des lignes infinies qui servent de références dans le dessin. Les lignes de construction peuvent être créées avec deux méthodes :

Guides par règles

Lorsque les règles sont visibles dans la zone de dessin principale (Affichage ▸ Afficher les règles), cliquez et faites glisser sur la règle horizontale ou verticale pour placer un guide aligné. Vous pouvez vous accrocher aux objets de dessin tout en faisant glisser pour placer le guide à l’endroit souhaité. Cette méthode fonctionne avec n’importe quel outil de dessin.

Guide par point

With this method you can create a construction line oriented at an arbitrary angle.

  1. Activez l’outil Objets de construction > Méthode Lignes de construction.
  2. Cliquez pour définir le centre et définissez la direction à l’aide du pointeur. Vous pouvez saisir un angle défini en appuyant sur la touche A du clavier ou en cliquant sur un objet linéaire existant pour dessiner une ligne de construction parallèle. Pour définir la distance de la ligne de construction par rapport à l’objet linéaire de référence, appuyez sur la touche L du clavier, saisissez la valeur et cliquez sur l’emplacement souhaité.

Vous pouvez créer un guide parallèle à un guide existant, comme un duplicata : avec la méthode Lignes de construction, cliquez sur une ligne de construction non sélectionnée dans le dessin et déplacez-vous. Utilisez le clavier pour entrer une distance contrainte.

Modification d’une ligne de construction

Les lignes de construction peuvent être déplacées comme n’importe quel autre objet : sélectionnez la ligne, cliquez n’importe où sur celle-ci et déplacez le pointeur. Pour contraindre la translation d’une distance définie, saisissez directement la longueur souhaitée et appuyez sur Retour ou Entrée.

Origine absolue

Cliquez pour changer l’origine des axes cartésiens et des règles. Les coordonnées du dessin et les dimensions sont mises à jour automatiquement. Vous pouvez également modifier l’origine en utilisant le bouton situé à l’intersection des règles. Dans HighDesign Professional, chaque feuille a sa propre origine. 


Lines

Probablement l’un des outils les plus utilisés, l’outil Ligne vous permet de tracer des lignes droites de n’importe quelle longueur et de n’importe quel angle, d’un point de départ à un point d’arrivée. 

Méthodes 

Single Line

Un segment de ligne allant d’une extrémité à l’autre.

Line by Center

Crée un segment de ligne à partir de son point central.

Segmented Line

Crée une série de lignes connectées. Cliquez pour définir le premier sommet, puis cliquez pour définir le sommet suivant. Pour terminer la série, double-cliquez sur le dernier sommet. Chaque segment est une ligne distincte.

Double Line

Crée deux segments parallèles de même longueur au niveau du décalage spécifié. Activez le champ Décalage à côté des icônes de méthode pour saisir une valeur. Les lignes doubles peuvent être tracées à partir de l’axe ou d’un côté.

La méthode standard pour tracer une ligne de longueur donnée consiste à définir le premier point, à appuyer sur la touche L (ou le raccourci correspondant), à entrer la valeur et à appuyer sur la touche Return. La même procédure s’applique aux angles (A), X, Y. D’autres méthodes sont décrites dans le chapitre Tâches de base.

Pour redimensionner une ligne, sélectionnez-la et, avec l’outil Ligne actif, cliquez sur l’une de ses extrémités. Cliquez sur son point central pour la déplacer. 


Poly-lines

L’outil Poly-ligne crée une forme polygonale composée d’une série de segments droits et courbes. Les segments courbes sont des arcs dessinés par le centre ou par la tangente. 

Pour dessiner une poly-ligne, cliquez pour définir le premier sommet, puis cliquez pour définir le sommet suivant. Pour terminer la chaîne, double-cliquez sur le dernier sommet.

Lors de la création d’une poly-ligne, une icône d’action suit le point de départ de chaque segment. Cliquez dessus ou survolez-la pour ouvrir le menu des options et choisir le type du segment suivant, supprimer le dernier segment ou terminer la forme. Pour fermer la poly-ligne, sélectionnez l’option correspondante ou placez le dernier sommet sur le premier. Les poly-lignes ont l’option de remplissage disponible dans la barre de propriétés.

Modifier une poly-ligne

Une poly-ligne peut être modifiée de plusieurs façons : activez l’outil Poly-ligne et sélectionnez l’objet (s’il n’est pas déjà sélectionné) ; puis :

  • cliquez sur un sommet pour l’étirer
  • cliquez sur un point central pour déplacer le segment entier
  • cliquez sur un segment pour ajouter un sommet
  • placer un sommet sur un autre sommet pour le supprimer
  • survolez le curseur sur un sommet pour ouvrir le menu “Edit”.

Le panneau d’information sur les objets offre davantage d’options d’édition :

  • Faites glisser le curseur Convexe pour modifier la convexité du segment actuel. Cette option permet de convertir facilement un segment droit en arc et vice-versa. La valeur du rayon est automatiquement mise à jour lorsque vous utilisez le contrôle de la convexité : vous pouvez également définir la valeur du rayon numériquement.
  • Utilisez l’interrupteur Closed pour fermer la polyligne. Le segment de fermeture prend le même type que le dernier segment ajouté.

Polygons

Utilisez cet outil pour dessiner des rectangles, des carrés et des polygones réguliers de n’importe quel nombre de côtés.

Méthodes 

Rectangle

Pour dessiner un rectangle, cliquez pour définir le premier sommet, déplacez le pointeur et cliquez à nouveau pour définir le sommet opposé. Vous pouvez ajouter des diagonales à un rectangle en appuyant sur la touche Option au deuxième clic. Pour dessiner un carré, utilisez l’outil rectangle et maintenez la touche Majuscule enfoncée pour contraindre la direction des diagonales. 

Pour définir la taille du rectangle, cliquez pour définir le sommet de départ, puis appuyez sur la touche “W” pour définir la largeur et “H” pour définir la hauteur. Les valeurs positives vont vers la droite et vers le haut. Pour modifier le rectangle avec l’outil Flèche ou l’outil Dessin actif, cliquez sur les sommets pour redimensionner, sur les points médians des côtés pour étirer, et cliquez sur les côtés ou le point central pour déplacer.

Rotated Rectangle

Cliquez pour placer le premier sommet, déplacez le pointeur et cliquez à nouveau pour définir l’angle de base ; puis déplacez le pointeur et cliquez une troisième fois pour définir la hauteur de la forme. Pour définir les dimensions, cliquez sur le premier sommet, appuyez sur la touche “A” pour définir l’angle, sur la touche “W” pour la largeur et sur la touche “H” pour la hauteur.

Rectangle par le centre

Cliquez pour définir le centre du rectangle ; déplacez et cliquez pour définir l’orientation et le premier axe ; déplacez et cliquez à nouveau pour définir l’axe perpendiculaire.

Polygone régulier par rayon extérieur

Cette méthode vous permet de dessiner des polygones réguliers avec un nombre quelconque de côtés à partir de trois. Pour définir le nombre de côtés souhaité, utilisez le champ de décalage dans la barre des méthodes à côté des méthodes de l’outil et insérez la valeur. 

Pour dessiner un polygone régulier par le rayon externe, cliquez pour définir le centre de la forme (tous ces polygones réguliers sont inscrits dans un cercle), déplacez le pointeur et cliquez à nouveau pour définir le rayon du cercle circonscrit et le sommet du polygone.

Polygone régulier par rayon interne

Cette méthode permet de dessiner le polygone en fixant le centre et le rayon du cercle inscrit dans le polygone.

Polygone régulier par côté

Crée un polygone défini par le côté. Pour créer le polygone, dessinez le premier côté, exactement comme une ligne de la longueur et de l’angle souhaités, puis cliquez à nouveau pour placer la forme à l’endroit voulu. 


Hachures et remplissages

Utilisez l’outil Hachures pour remplir des régions polygonales avec une couleur, une hachure vectorielle linéaire, un motif vectoriel tuilé ou une texture. Cet outil dispose de quatre méthodes : Hachure de la région, Hachure au clic, Îles polygonales et Îles circulaires.

Les hachures peuvent être choisies dans une liste de types : HighDesign est livré avec une large gamme de hachures intégrées qui peuvent être facilement complétées par vos propres hachures. Vous pouvez également combiner des remplissages et des trappes. 

Pour définir ou modifier les attributs des hachures, sélectionnez Édition ▸ Fenêtre des paramètres ▸ Motif des hachures ou double-cliquez sur l’icône correspondante dans la barre d’outils pour ouvrir la fenêtre Paramètres des hachures et du remplissage. 

Fenêtre de paramétrage des hachures et des remplissages

La fenêtre Paramètres affiche toutes les options pour les propriétés graphiques spécifiques à l’outil ainsi que les contrôles et les champs pour la configuration de l’outil.

Dans la barre supérieure de la boîte de dialogue, près du titre, se trouve le bouton triangulaire qui permet de sélectionner et de charger les styles existants : à droite se trouve l’icône Ajouter qui permet de créer un nouveau style avec les paramètres actuels. Ces caractéristiques générales de la barre de titre de la fenêtre Paramètres sont partagées par tous les outils de dessin avec des paramètres spécifiques. 

Les options de réglage sont les suivantes :

  • Bordure : sélectionnez cette option pour afficher la bordure de la région hachurée et sélectionnez sa couleur. 
  • Remplissage : sélectionnez cette option pour ajouter une couleur solide ou un dégradé de remplissage. Utilisez le bouton de couleur de remplissage pour sélectionner la couleur et les options. 
  • La case à cocher Hachure/Texture active le hachurage vectoriel de la région ; la couleur du hachurage peut être sélectionnée via le menu Couleur du stylo dans la barre des propriétés. 
  • Facteur d’échelle : utilisez ce curseur pour mettre à l’échelle les espacements et les décalages de la hachure ou pour redimensionner la tuile de la texture. 
  • Dessiner à l’échelle : ajuste l’échelle de la hachure pour qu’elle corresponde à l’échelle actuelle de la feuille, de manière à redimensionner la hachure en conséquence. Cette option est particulièrement utile lorsque la hachure représente un élément de construction réel comme un plancher ou un mur. 
  • Rotation : contrôle l’angle de rotation de tous les motifs de la trappe. Les textures ne peuvent pivoter que de 90 degrés.
  • Tableau des hachures : liste tous les types de hachures installés, y compris les types personnalisés. 
  • La dernière cellule du tableau des hachures est un bouton spécial : cliquez dessus pour ajouter des types de hachures au projet actuel. Cette option ouvre le volet “Modèles de hachures” de la fenêtre du gestionnaire de ressources. 

Dessiner et modifier une hachure / un remplissage

  • Pour dessiner une région de hachures/remplissage, utilisez cet outil de la même manière que l’outil Poly-ligne ou sélectionnez un polygone existant et choisissez Outils ▸ Appliquer des hachures. Pendant le dessin d’une région Hatch / Fill, il est possible de supprimer le dernier sommet en cliquant sur l’icône X qui lui est proche. 
  • Pour modifier un sommet d’une région hachurée, sélectionnez l’objet et, avec l’outil Hatch actif, déplacez le pointeur sur le sommet jusqu’à ce que le menu d’outils s’affiche avec les options de modification. 
  • Pour ajouter un sommet, cliquez sur un côté ou sur l’option “Ajouter un sommet” du menu ; pour effacer un sommet, déplacez le pointeur sur ce sommet et cliquez sur l’option correspondante du menu d’outils. 
  • L’option “Ajuster l’arc au clic” s’affiche lorsque le pointeur se trouve sur le point de départ d’un arc et permet à l’utilisateur de modifier la hachure sélectionnée et d’ajuster l’arc en cliquant dessus.

Les trappes peuvent également être insérées sur des formes homogènes par un clic sur leur contour. Les hachures peuvent également être insérées sur des formes homogènes par un clic sur leur contour. 

Les hachures et les remplissages peuvent accueillir plusieurs ouvertures de formes polygonales et circulaires. Ces ouvertures sont appelées îlots et il existe deux méthodes d’outils différentes pour les créer.

Méthodes 

Région des hachures

Pour définir une région hachurée polygonale, cliquez sur chaque sommet de la région et double-cliquez pour terminer.

Éclosion au clic

Il est possible d’appliquer la hachure actuelle à des formes homogènes telles que des poly-lignes, des rectangles, des polygones, des cercles, des arcs, des ellipses, des mains libres, des courbes en un clic : il suffit d’activer la méthode et de cliquer sur le contour de la forme que vous souhaitez hachurer. 

Les régions entourées de murs connectés peuvent être hachurées par un clic à l’intérieur.

Île polygonale

Sélectionnez cette méthode pour créer des ouvertures polygonales dans des hachures existantes en dessinant les formes des îlots à l’intérieur de la sélection. Pour ce faire, il suffit d’activer l’outil Hachures et remplissages, de sélectionner la méthode et de cliquer sur les sommets de l’ouverture polygonale que vous souhaitez créer dans la hachure. Cette méthode peut être utilisée sur les hachures sélectionnées et non sélectionnées. La hachure la plus proche est détectée automatiquement lorsque vous déplacez le curseur sur le projet.

Île circulaire

Cette méthode vous permet d’ouvrir des îlots circulaires définis par un centre et un rayon. Cliquez pour définir le centre et cliquez à nouveau pour définir le rayon : il est également possible de définir la valeur du rayon numériquement.

Pour modifier l’îlot, sélectionnez la hachure et placez le pointeur sur un sommet de l’ouverture jusqu’à ce que le menu d’outils s’affiche, vous donnant les options pour supprimer l’îlot, supprimer un sommet ou en ajouter un autre. 


Cercles, arcs, ellipses

Utilisez cet outil pour dessiner des cercles, des arcs, des ellipses et des arcs d’ellipse. Toutes les méthodes pour les arcs de cercle peuvent être utilisées pour dessiner des cercles complets en cliquant sur l’interrupteur qui apparaît à l’écran à côté du premier point de l’arc, ou en maintenant la touche Alt enfoncée. 

La construction peut être à la fois graphique, via des clics sur le dessin, ou numérique via la saisie au clavier. 

Méthodes

 Arc/Cercle par Centre et Rayon

Pour dessiner un arc ou un cercle, cliquez pour définir le centre (ou définissez-le avec des coordonnées), puis sélectionnez l’option arc ou cercle sur le bouton flottant à l’écran.

Pour dessiner un arc, définissez le rayon en appuyant sur la touche L, définissez l’angle de départ en appuyant sur la touche A et définissez l’angle final en appuyant à nouveau sur A. Pour dessiner un arc graphiquement, déplacez le pointeur et cliquez à nouveau pour définir l’angle de départ ; le clic suivant permet de définir l’angle final de l’arc. 

To draw a full circle, set the length of the radius by pressing the L key on the keyboard and the start angle / end angle by pressing the A key. Press Return to confirm.

Arc/Cercle par diamètre

Cliquez pour définir le premier sommet du diamètre, déplacez le pointeur et cliquez à nouveau pour définir le second sommet. Vous pouvez définir le diamètre en appuyant sur la touche L, et l’angle en appuyant sur la touche A. 

Arc/Cercle par point de départ, point d’arrivée, rayon

Cliquez pour définir le point de départ et le point d’arrivée de l’arc et cliquez pour définir le rayon. Les deux points et le rayon peuvent également être définis par saisie numérique en utilisant les coordonnées X, Y et Dx, Dy et la valeur L. Maintenez la touche “alt” enfoncée pour changer la direction de l’arc.  

Arc/Cercle par trois points

Cliquez pour définir les points qui définissent l’arc. Les trois points peuvent également être définis par saisie numérique en utilisant les coordonnées X, Y ou les valeurs L et A.

Arc/Cercle par Tangente

Cliquez sur l’extrémité d’une ligne ou sur l’extrémité d’un arc pour définir le premier point de l’arc dessiné par la tangente à cet objet à l’extrémité de cette donnée. 

Ellipse par boîte englobante

Définir le point de départ, déplacer et définir le point d’arrivée de la diagonale. L’ellipse est inscrite dans le rectangle défini par sa diagonale. 

Ellipse par centre et rayons

Cliquez pour définir le centre de l’ellipse, déplacez et cliquez pour définir son premier rayon ; déplacez à nouveau et cliquez pour définir son second rayon. Le centre peut également être défini à l’aide des coordonnées X, Y et les rayons peuvent être définis en appuyant sur la touche L pendant leur construction. 

Quart d’ellipse

Cette méthode permet de dessiner les quartiers d’une ellipse en cliquant sur ses deux sommets.   


Courbes

L’outil Courbes vous permet de dessiner des courbes de Bézier simples ou multiples, des lignes à main levée, des courbes Spline et des nuages. 

Méthodes 

Courbes de Bézier

Cette méthode peut être utilisée pour dessiner des trajectoires de Bézier multiples et connectées, des courbes paramétriques définies par deux sommets et deux lignes tangentes : 

  • cliquez pour définir le premier sommet, déplacez le pointeur et cliquez pour définir le sommet suivant ; double-cliquez pour terminer la chaîne de courbes de Bézier. 

Le chemin résultant peut maintenant être édité pour lisser les sommets et transformer les segments droits en courbes souhaitées : de cette façon, la première tangente de la courbe suivante est toujours définie par la précédente. Les courbes de Bézier ont la propriété Fill : sélectionnez la couleur souhaitée dans le menu “Fill color” de la barre de propriétés. Editer une courbe de Bézier 

  • Placez le curseur sur un sommet de la courbe sélectionnée pour afficher le menu contextuel avec les options permettant d’ajouter ou de supprimer des sommets et d’adoucir ou d’affiner la trajectoire en créant des courbes connectées ou des segments droits.
  • En cliquant sur l’un des quatre points de contrôle d’une courbe sélectionnée, vous pouvez modifier sa position et ajuster visuellement le profil. Avec des courbes de Bézier multiples, en modifiant un point de définition, les tangentes connectées sont contraintes de conserver le même angle : déplacez les points de contrôle des tangentes pour modifier l’angle et ajuster la forme de la courbe. 
  • Maintenez la touche Alt enfoncée tout en déplaçant les points de contrôle des tangentes pour éditer de manière asymétrique ; touche Alt + touche Cmd pour déconnecter les tangentes.

Freehand

La méthode à main levée vous permet de créer des courbes splines en suivant le mouvement du curseur. La méthode à main levée possède deux propriétés : le facteur de lissage, qui définit la complexité de la courbe, et l’option de dessin. Vous pouvez ajuster le facteur de lissage des nouveaux tracés par le biais de la fenêtre des paramètres à main levée : 1 signifie que le chemin conservera sa forme d’origine, mais pourrait avoir de nombreux sommets ; 6 est le lissage maximal et le chemin sera considérablement simplifié.

Dans le même volet, vous pouvez également choisir de dessiner des tracés à main levée en utilisant la méthode du cliquer-glisser au lieu du clic-cliquer standard : cette option est particulièrement utile lorsqu’elle est utilisée avec une tablette à stylet, car elle permet de dessiner de manière plus naturelle avec un stylet.

Spline 

Les courbes splines dans HighDesign sont des B-splines cubiques, des courbes continues tracées à travers un ensemble donné de points : pour créer une courbe spline, cliquez pour définir les points qui définissent la forme de la courbe. Double-cliquez sur le dernier point pour terminer la courbe. Choisissez la couleur de remplissage dans le menu correspondant de la barre de propriétés. 

Modification d’une courbe Spline et d’un chemin à main levée
  • Passez le curseur sur un sommet de la courbe sélectionnée pour afficher le menu contextuel avec les options d’ajout ou de suppression de points ;
  • Déplacez les points donnés de la courbe sélectionnée avec l’outil Flèche ou avec le pointeur et la méthode d’outil Spline ou Freehand active. 

Nuage de révision

Cette méthode vous permet de créer un groupe composé de chaînes d’arcs connectés. Vous pouvez utiliser cet outil pour dessiner un ensemble personnel de nuages de révision à sauvegarder comme symboles pour des utilisations futures.


Symboles

L’outil Symboles est un outil de dessin qui vous permet de placer dans votre projet des dessins entiers ou des portions de dessins déjà créés et stockés dans une bibliothèque en un seul clic. L’utilisation des symboles est un moyen pratique pour reproduire plusieurs fois le même groupe d’éléments avec des facteurs de rotation, de miroir et d’échelle indépendants. 

Les symboles peuvent inclure des attributs, qui sont des informations affichées à l’endroit souhaité de la vue actuelle.

Pour modifier ou définir les propriétés de l’outil Symbole, sélectionnez Édition ▸ Fenêtre des paramètres ▸ Symbole ou double-cliquez sur l’icône de l’outil Symbole dans la barre des outils de dessin.

Fenêtre de paramétrage des symboles 

La boîte de dialogue des paramètres du symbole comporte deux volets : Symbole et Attributs. Le volet Symbole vous offre de nombreuses options pour choisir un nouveau symbole et définir ses propriétés graphiques. 

  • Le tableau présente le dossier de bibliothèque actuellement sélectionné : ce dossier peut contenir de nombreux sous-dossiers et peut être organisé selon votre choix. Naviguez dans ce tableau pour sélectionner le fichier de symbole. 
  • Une fois qu’un symbole a été sélectionné, une liste de toutes ses vues s’affiche si elle est disponible : sélectionnez une vue dans la liste pour l’activer ; double-cliquez sur son nom pour le modifier et cliquez sur l’icône crayon pour éditer le symbole/la vue (pour les symboles personnalisés uniquement). 
  • La boîte d’aperçu affiche une vignette du symbole sélectionné avec les paramètres actuels. 
  • Les paramètres géométriques du symbole sont : la largeur, la hauteur (qui peut être redimensionnée proportionnellement), l’angle (en degrés) ; Sous les champs de saisie, les boutons Transformations rapides permettent de mettre le symbole en miroir. Les propriétés du symbole sont les options de remplissage et de couleur et l’option de mise à l’échelle du symbole en fonction de l’échelle actuelle du dessin. 
  • En bas sont regroupés les boutons pour (de gauche à droite) créer un nouveau dossier, créer un nouveau symbole à partir des objets sélectionnés, dupliquer le symbole sélectionné, ajouter une nouvelle vue à un symbole existant et supprimer l’élément sélectionné.

Le volet Attributs affiche les attributs facultatifs de la vue actuelle. Utilisez ce volet pour définir les valeurs des attributs du symbole ou de la vue du symbole que vous insérez dans le projet ou pour modifier les valeurs de la sélection actuelle.

Créer et modifier des symboles

Les fonctions “Nouveau symbole” et “Modifier le symbole”, également disponibles dans le menu Projet, permettent, lorsqu’elles sont activées, de passer à un espace de travail différent avec un ensemble limité d’outils : dans cet environnement, vous pouvez dessiner, modifier et enregistrer des symboles et des vues de symboles. 

Vous pouvez soit créer un nouveau symbole à partir de zéro, soit créer un nouveau symbole à partir de la sélection : dans ce cas, vous pouvez également activer cette fonction via le Menu Radial pour un flux de travail plus rapide. De cette façon, les objets sélectionnés sont maintenant visibles dans l’environnement “Editer le symbole” alors que tous les autres éléments du dessin sont cachés. 

Créer un nouveau symbole

  1. Sélectionnez “New Symbol” dans le menu Project ; 
  2. L’environnement passe au contexte “Edit Symbol” avec un ensemble limité d’outils et le dialogue “New Symbol” s’ouvre ; ce dialogue est divisé en quatre sections :
  • Nom du symbole ;
  • Vue ;
  • Attributs ;
  • Points d’insertion ;
  • Dessinez le symbole ;
  • Tapez le nom du symbole ; 
  • Sélectionnez le dossier de destination à l’aide du bouton dossier ; 
  • Utilisez le bouton “+” pour ajouter une nouvelle vue ; 
  • Tapez le nom de la vue ; 
  • Définir les attributs ;
  • Insérez les attributs dans le dessin de la vue du symbole ;
  • Placez les points d’insertion aux endroits désirés de la vue du symbole ;
  • Appuyez sur le bouton “Enregistrer” de la boîte de dialogue. 

Attributs du symbole

Les attributs sont des informations ajoutées à la vue courante du symbole : ces informations sont définies par un ID, une Prompt, affichée à l’écran, et une valeur par défaut qui sera affichée dans le projet.

La section Attributs de la boîte de dialogue Nouveau symbole s’affiche : 

  • Le menu des attributs existants de la vue (visible lors de l’édition d’un symbole et de ses attributs) ;
  • Le bouton Ajouter pour créer un nouvel attribut ;
  • Le bouton pour supprimer les attributs sélectionnés,
  • Le bouton “Modifier l’attribut” pour modifier l’attribut actuellement sélectionné.

Les attributs étant une sous-classe du texte, ils peuvent obtenir des propriétés du texte telles que la police, la taille de la police, l’alignement, le style et l’angle de rotation : la fenêtre “Définir l’attribut” affiche toutes ces informations et options.

Pour insérer l’attribut, il suffit de cliquer sur l’emplacement souhaité dans la vue des symboles.

Modifier un symbole

Pour modifier un symbole, vous pouvez cliquer sur le bouton Modifier du symbole sélectionné dans la fenêtre Paramètres, ou sélectionner le symbole sur le dessin et choisir “Modifier le symbole” dans le menu Projet ou utiliser le menu radial. 

L’espace de travail “Editer le symbole” s’ouvre et vous pouvez modifier le symbole, ajouter des vues au symbole en appuyant sur le bouton “+” du dialogue ou supprimer des vues grâce au bouton “-“, changer les attributs de la vue.

En appuyant sur le bouton “Enregistrer”, l’environnement revient à “Dessin”. Les modifications apportées à un symbole sont immédiatement visibles dans tous les duplicatas de symboles du dessin. 

Insertion d’un symbole dans le dessin 

  • Ouvrez la boîte de dialogue Bibliothèque de symboles en choisissant Édition ▸ Fenêtre des paramètres ▸ Symbole ou en double-cliquant sur l’icône Symbole dans la barre d’outils Dessin ; 
  • Sélectionnez un symbole dans le tableau Dossiers et choisissez l’une des vues disponibles ; 
  • Définissez sa taille et ses paramètres optionnels ; 
  • Vérifiez ou modifiez les attributs par défaut s’ils sont disponibles ;
  • Cliquez sur l’un des points d’insertion définis, le centre ou l’un des sommets ou points médians de la vignette pour sélectionner le point d’insertion actuel ; 
  • Faites glisser l’aperçu sur le dessin ou cliquez sur le point souhaité du dessin. 

Pour créer un nouveau symbole, pour ajouter une vue à un symbole ou pour modifier un symbole existant, les commandes spécifiques du menu Projet sont également disponibles. 


Images

Les images dans HighDesign peuvent être insérées via la commande “Insérer une image” du menu Fichier. Les types de fichiers pris en charge sont TIFF, JPG, PNG, GIF, BMP et PDF. Les niveaux alpha présents dans les fichiers TIFF et PNG sont préservés. 

Vous pouvez également faire glisser une image depuis un autre programme, tel qu’un navigateur Web, ou un fichier directement sur le canevas de dessin. 

Insérer une image

HighDesign vous permet d’ajouter facilement des images à votre projet à partir de plusieurs formats graphiques (TIFF, JPEG, PNG, GIF, PDF). Les images insérées dans le projet conservent leur résolution et sont affichées à la taille réelle d’impression : il est également possible de les manipuler comme toute autre entité vectorielle. Les images PNG et TIFF sont importées avec leur canal alpha s’il est présent. 

Pour insérer une image dans votre projet, sélectionnez Fichier ▸ Insérer une image…, choisissez l’image et placez-la à l’endroit souhaité d’un clic. Vous pouvez également ouvrir la fenêtre des paramètres de l’image en double-cliquant sur l’outil Insérer une image dans la barre d’outils du projet et en appuyant sur le bouton Ouvrir une image. Vous pouvez également faire glisser une image à partir d’une autre application, telle qu’un navigateur Web, faire glisser un fichier directement sur le canevas de dessin, ou utiliser la commande Coller pour coller une image à partir du presse-papiers. 

L’outil Insérer une image offre une fenêtre contextuelle permettant de sélectionner rapidement les images utilisées dans le projet en cours ou récemment chargées.

Les documents PDF peuvent être insérés comme des images à haute résolution. Lorsque vous choisissez un document PDF à l’aide de la commande Insérer une image, une boîte de dialogue s’affiche dans laquelle vous pouvez sélectionner la page à importer, s’il y en a plusieurs, et définir la résolution à laquelle l’objet image sera créé. 

Les images peuvent être déplacées, redimensionnées et pivotées, soit via les outils d’édition, soit via le panneau d’information sur les objets, soit via la fenêtre des paramètres de l’image.

Paramètres de l’image 

La fenêtre Paramètres d’image affiche les options suivantes pour définir la taille à l’écran, la taille d’impression, la résolution et la transparence des images : 

  • Taille : les dimensions de l’objet image dans le projet, mesurées en points, millimètres, pouces ou pourcentage ;
  • Résolution de l’image, en points par pouce. 
  • Affichage à la résolution de l’écran : lorsqu’elle est active, l’image est toujours affichée à la résolution de l’écran, qui est généralement inférieure à celle du papier. La taille visible de l’image est plus grande aux résolutions inférieures.
  • Bouton “Restaurer les valeurs d’origine”, pour réinitialiser la taille et la résolution de l’image comme dans l’image source.
  • Transparence : définit le degré de transparence avec lequel l’image est affichée. Les valeurs vont de 0%, totalement opaque, à 100%, totalement transparent. 
  • Format de fichier : les images sont traitées comme d’autres objets vectoriels et enregistrées dans le fichier du projet. Le format interne peut être soit PNG, qui préserve la qualité totale de l’image, soit JPEG, qui compresse l’image et réduit considérablement la taille du fichier, mais en réduit la qualité. Le format JPG est très bon pour les images photographiques, mais pas pour les images qui contiennent des dessins au trait, comme les plans de ville ou les dessins scannés. 

Les champs Taille et Résolution de l’image permettent des modifications numériques. Veuillez noter que le rapport Taille/Résolution est constant et que, par conséquent, lorsque vous modifiez la taille, la résolution change en conséquence et vice versa.

Utilisez le bouton “Info” près de l’aperçu de l’image pour afficher les informations de l’image source sur sa toile d’aperçu. Les informations fournies sont : la taille du fichier, les dates de création et de modification, l’emplacement du fichier, les dimensions de l’image exprimées en pixels et sa résolution.

Lorsque le pointeur survole l’aperçu de l’image, le bouton “Remplacer l’image” apparaît : cliquez dessus pour sélectionner une nouvelle image source à insérer dans la zone d’image existante.


Groupes

HighDesign offre la possibilité de regrouper différents objets en un seul élément. La plupart des opérations d’édition et des transformations ne peuvent être appliquées qu’aux éléments sélectionnés, soit à des objets individuels, soit à un groupe d’objets à la fois. 

Les groupes sont un moyen pratique d’organiser des éléments en liant des éléments hétérogènes dans une “collection” qui se comporte comme un seul objet. Une fois qu’un certain nombre d’objets de dessin sont regroupés, vous pouvez les sélectionner en cliquant simplement sur l’un des membres du groupe. Par défaut, les objets regroupés conservent leurs attributs, tels que la couleur, le type de ligne, le poids, etc. La modification des attributs d’un groupe s’applique à tous ses membres. 

Commandes pour les groupes

Toutes les commandes liées aux groupes sont disponibles dans le menu Projet. Les fonctions permettant de gérer les groupes sont les suivantes : grouper, dégrouper, regroupement automatique, dégrouper tout, modifier le groupe. 

  • “Grouper” crée un nouveau groupe avec tous les éléments actuellement sélectionnés ; 
  • “Dégrouper” rompt les groupes sélectionnés ;
  • “Ajouter au groupe” inclut les objets sélectionnés dans le groupe actuellement sélectionné ; 
  • “Automatic Grouping” est une option qui crée automatiquement des groupes avec des éléments d’une forme, c’est-à-dire des rectangles, des polygones réguliers, des poly-lignes, des murs, etc ; 
  • “Dégrouper tout” brise tous les groupes, y compris ceux qui ne sont pas sélectionnés.
  • “Modifier le groupe” ouvre un espace de travail où vous pouvez modifier le groupe sélectionné en éditant, ajoutant ou supprimant des membres à l’aide des outils de dessin normaux. 

Modifier un groupe

Les objets groupés peuvent être édités tous ensemble comme un seul objet de dessin en étirant les poignées de la boîte de délimitation du groupe avec l’outil Flèche. Un groupe peut être déplacé, pivoté, mis en miroir ou mis à l’échelle comme tout autre objet.

  • Un groupe peut être redimensionné et déplacé avec l’outil Flèche. Les propriétés appliquées à un groupe sont appliquées à tous les membres du groupe.
  • Pour sélectionner des membres individuels d’un groupe, maintenez la touche Commande enfoncée et cliquez sur l’objet. L’objet sera sélectionné et pourra être modifié ou supprimé. Cette méthode est plus adaptée aux opérations d’édition rapides. 
  • Vous pouvez également modifier les membres d’un groupe à l’aide de la commande Edit Group.

L’espace de travail “Modifier le groupe”

Vous pouvez activer l’espace de travail Modifier le groupe en sélectionnant un groupe et en cliquant sur l’icône Modifier sur le point de poignée supérieur gauche ou en choisissant Projet ▸ Modifier le groupe…. Cet espace de travail ouvre un panneau contenant des commandes spécifiques qui vous permettent de gérer les sous-groupes, d’afficher ou de masquer le contexte, d’ajouter des objets au groupe ou d’en supprimer.

Si le groupe comprend des sous-groupes, vous pouvez utiliser le menu Sous-groupes pour activer n’importe quel sous-groupe ou revenir au groupe principal. Pour modifier un sous-groupe, cliquez sur l’icône Modifier au-dessus de son coin supérieur gauche. Cliquez sur “Done” pour terminer l’édition.

Par défaut, le groupe édité est affiché dans son contexte, c’est-à-dire les objets environnants du dessin dans lequel il est inséré. Vous pouvez ajuster le niveau d’opacité du contexte ou le désactiver complètement.

Pour ajouter un objet existant au groupe, appuyez sur le bouton Add Object dans la section Actions et cliquez sur n’importe quel objet du contexte. De la même manière, appuyez sur le bouton Supprimer un objet et cliquez sur n’importe quel objet du groupe pour le retirer du groupe. L’objet retiré sera déplacé vers la feuille où se trouve son groupe d’origine.

Vous pouvez également dessiner n’importe quelle classe d’objet à l’aide des outils disponibles dans la boîte à outils. Tout objet créé de cette manière sera ajouté au groupe actuel.

Appuyez sur Done pour confirmer les modifications et revenir à l’espace de travail normal, ou appuyez sur Cancel pour annuler toutes les modifications apportées dans l’espace de travail Edit Group.

Was this article helpful to you? Yes No 1

How can we help?