1. Home
  2. Docs
  3. Français : Aide et documentation
  4. Guide d’utilisation de HighDesign
  5. 19. Outils avancés

19. Outils avancés

Vues du projet, photogrammétrie, édition d’images, présentation de dessins
Sujets dans cette section

Vues du projet(Pro)

Une vue de projet est un instantané du projet qui enregistre un état spécifique de la position et du zoom de la vue, de la visibilité des feuilles et des calques. Les vues sont nommées et répertoriées dans le panneau Vues de projet avec leur vignette.

Les vues de projet peuvent également être utilisées comme un moyen alternatif de créer des présentations prêtes à être imprimées : en plus des feuilles et des mises en page, la fenêtre d’impression vous permet de sélectionner une vue de projet spécifique.

  • Une vue de projet stocke l’état de visibilité des feuilles et des couches actuelles et vous permet de créer, par exemple, une “mise en page” d’un plan avec les dimensions et les surfaces et une autre “mise en page” du même plan (feuille) avec les services uniquement. 
  • Grâce à l’option de transparence des feuilles de dessin et en combinant les feuilles et les couches visibles, vous pouvez créer des vues de projet complexes pour vos impressions : dans la fenêtre d’impression, vous pouvez sélectionner la vue de projet que vous souhaitez imprimer via le menu Vues.

Les vues de projet stockent les données suivantes :

  • Position et facteur de zoom de la vue actuelle
  • Couches visibles et opacité des couches
  • Feuilles de travail visibles

Gestionnaire de vues

Le panneau “Vues” fournit une liste de toutes les vues de projet enregistrées. Un aperçu en direct des vues s’affiche lorsque le pointeur se trouve sur le nom d’une vue. Cliquez sur le nom d’une vue pour l’activer ou double-cliquez pour la renommer.

  • Pour ajouter une vue, cliquez sur le bouton “Enregistrer la vue actuelle” et tapez un nom : les vues enregistrées comprennent la position, le facteur d’agrandissement et les feuilles et couches visibles. 
  • Pour supprimer la vue actuellement sélectionnée, cliquez sur le bouton “Supprimer la vue”. 
  • Le bouton “Mettre à jour la vue” redéfinit la vue sélectionnée à partir des paramètres actuels. 

Photogrammétrie

HighDesign Pro est un outil puissant de photogrammétrie mono-image permettant d’obtenir la projection réelle des éléments architecturaux capturés dans une image : cette fonction peut être utilisée pour les relevés de façades architecturales et de toute surface plane et ne nécessite qu’un appareil photo normal et deux mesures. Aucun équipement spécifique ni aucune connaissance ne sont nécessaires.

La photogrammétrie dans HighDesign offre deux méthodes d’outils : 

  • Correction d’image : transforme l’image originale en rectifiant la déformation de la perspective. 
  • Traçage de la perspective : crée une projection corrigée en traçant les éléments de l’image après avoir défini la géométrie interne de l’image. Toutes les projections sont basées sur des vecteurs. 

Vous trouverez ci-dessous quelques exigences et suggestions pour obtenir les meilleurs résultats : 

  • L’image doit comporter au moins deux éléments horizontaux et deux éléments verticaux (par exemple, une porte, une fenêtre, des briques de mur) et, si possible mais pas strictement nécessaire, deux éléments avec la troisième dimension. Ces exigences sont les seules réellement nécessaires pour utiliser l’outil de photogrammétrie dans HighDesign. 
  • Si possible, évitez les vues trop inclinées car la projection pourrait être déformée sur les bords de l’image ; 
  • Pour la même raison que ci-dessus, évitez les objectifs fisheye (<28 mm) ; 
  • L’image doit comporter au moins une dimension horizontale et une dimension verticale ; toutefois, si vous ne disposez pas de ces dimensions, vous pouvez configurer la projection avec n’importe quelle dimension et redimensionner ultérieurement le dessin résultant. 

En règle générale, il faut s’assurer que l’image comporte des éléments de référence et qu’elle n’a pas été découpée ou déformée. Lorsque la troisième direction (profondeur) n’est pas disponible, la géométrie interne de la vue repose sur les diagonales du rectangle de l’image, d’où l’importance de préserver la forme originale de l’image. 

Définir les données requises 

Le processus d’installation est très simple et ne nécessite aucune connaissance spécifique. 

Pour lancer une photogrammétrie, sélectionnez Tools ▸ Photogrammetry. HighDesign passe à l’espace de travail Photogrammétrie, avec la fenêtre de configuration de la photogrammétrie, un fond gris et un ensemble limité d’outils de dessin : 

  • Flèche ;
  • Objets de construction ;
  • Lignes ;
  • Poly-lignes avec segments droits ;
  • Hachures ;
  • Courbes ;
  • Outils de visualisation (Panoramique, Zoom et Mesure). 

ÉTAPE 1 : sélectionner l’image

Appuyez sur le bouton “Choisir…” et sélectionnez le fichier image à ouvrir. Les types de fichiers pris en charge sont : TIFF, PNG, JPEG. 

Appuyez sur le bouton “Suivant” : l’image est maintenant affichée à l’écran et la fenêtre de configuration de la photogrammétrie change. 

ÉTAPE 2 : définir la géométrie interne 

Une fois l’image ouverte, sélectionnez le type géométrique de l’objet dans l’image. Il existe deux options possibles, basées sur la géométrie visible et l’angle de la caméra :

  • Les trois directions X, Y et Z sont visibles sur l’image : il y a au moins deux lignes horizontales, deux verticales et deux pour la profondeur ; 
  • Deux directions X, Y sont visibles. L’image montre au moins deux lignes horizontales et deux verticales, mais aucune ligne de profondeur n’est visible ; ce type comprend les photos prises avec l’objectif parallèle à la surface et les scans de plans.

Lorsque vous choisissez le type de géométrie, une grille est ajoutée à l’image sur la zone de dessin. Ajustez la grille pour qu’elle corresponde à la forme de l’objet dans l’image.

Cliquez sur les poignées de la grille sur ses sommets et déplacez-les jusqu’à ce qu’elles correspondent aux lignes de repère horizontales et verticales qui sont visibles dans l’image. Les fenêtres, les murs latéraux, les seuils, les montants des portes et des fenêtres et les cadres sont tous des éléments utiles.

Si la géométrie montre deux côtés de l’objet, une deuxième grille sert à la reconstruction de la troisième direction. Faites glisser les deux lignes de profondeur bleues par leurs extrémités pour qu’elles correspondent aux lignes de repère de profondeur sur l’image. Vous pouvez ajuster la grille et les lignes de profondeur en gardant à l’esprit que les lignes éloignées du centre de l’image ont généralement une déformation qui dépend de la qualité et de la longueur focale de l’objectif utilisé.

  • La valeur de la distance focale est facultative. 

Appuyez sur le bouton “Next” pour passer à l’étape suivante de la configuration.

ÉTAPE 3 : définir les mesures connues 

Deux lignes, une verte verticale et une rouge horizontale, sont affichées sur l’image. Ces lignes, tracées dans la vue perspectiviste correspondant à la géométrie interne de l’image, seront utilisées pour entrer les deux mesures connues.

  • Faites glisser la ligne verticale sur la dimension connue, dans ce cas le montant de la porte cintrée, et étirez-la/raccourcissez-la par les points d’extrémité jusqu’à ce qu’elle corresponde à l’objet connu : entrez la mesure verticale connue dans le champ correspondant de la fenêtre flottante de configuration et sélectionnez les unités de dessin.
  • Faites glisser la ligne horizontale sur l’objet connu, le seuil de la porte, ajustez-la jusqu’à ce qu’elle corresponde à la dimension connue et entrez la mesure réelle dans le champ correspondant et réglez l’échelle de dessin de la projection.

ÉTAPE 4 : choisir le mode de projection 

La configuration est maintenant terminée et il est possible de choisir le mode de projection entre la déformation de l’image et la projection vectorielle. En choisissant la déformation d’image, l’image sera étirée pour corriger la déformation de perspective et correspondre aux proportions données : l’image résultante pourrait alors devoir être redimensionnée pour correspondre aux mesures connues. 

La deuxième option, “Tracer et projeter”, consiste à tracer tous les objets de l’image que vous souhaitez relever pour obtenir la projection à l’échelle de dessin souhaitée.

Dessiner et visualiser des éléments projetés  

Comme nous l’avons déjà mentionné, l’espace de travail de l’outil Photogrammétrie fournit un ensemble limité d’outils de dessin et trois feuilles sont répertoriées dans la barre latérale : “Feuille 1”, la feuille créée par défaut lorsque vous lancez HighDesign ; “Photogrammétrie”, qui stocke l’image et toutes les données de configuration et c’est la feuille que vous utilisez pour tracer tous les objets à projeter ; “Projection”, qui est affichée comme une fenêtre flottante lorsque vous êtes sur la feuille “Photogrammétrie”. De plus, cet espace de travail a les caractéristiques suivantes : 

  • Les directions sont contraintes aux points de fuite ; en maintenant la touche Shift enfoncée pendant le dessin ou le traçage des lignes, les directions sont contraintes au point de fuite le plus proche, vertical ou horizontal.
  • La fenêtre Projection affiche le résultat de toutes les projections, c’est-à-dire que tous les éléments dessinés dans l’environnement Photogrammetry sont projetés en temps réel à l’échelle de dessin précédemment définie. 

La feuille “Projection”, comme toutes les feuilles de dessin, peut être utilisée pour dessiner, modifier, enregistrer et exporter la projection comme un dessin séparé.

Utilitaires de photogrammétrie

Le menu Outils comprend certaines commandes spécifiques à l’espace de travail Photogrammétrie et vous permet de gérer certaines fonctions importantes : 

  • Photogrammétrie : permet de lancer une nouvelle projection photogrammétrique ou de reprendre la projection en cours.
  • Reset Photogrammetry : efface tous les paramètres (géométrie et dimensions connues) et ramène le processus de photogrammétrie à l’étape de configuration ; la fenêtre de configuration s’ouvre à nouveau et tous les éléments projetés sont supprimés. Veuillez faire attention lorsque vous utilisez cette commande car elle n’est pas annulable. 
  • Quitter la photogrammétrie : masque l’image du projet et met en pause l’environnement de photogrammétrie en basculant l’espace de travail sur Projet. Les éléments dessinés sur la feuille actuelle ne sont pas supprimés ; sélectionnez “Photogrammetry” pour reprendre la photogrammétrie. 

Modifier les images

HighDesign vous permet d’insérer des images dans un projet et de les traiter comme tout autre objet vectoriel. L’outil Modifier l’image (menu Outils) vous permet de modifier et de recadrer l’image, de l’améliorer et de régler les valeurs de luminosité, de contraste et de saturation.

Il arrive souvent d’avoir besoin d’ajuster la luminosité, le contraste, les niveaux de couleur d’une image destinée à être utilisée pour une projection photogrammétrique ou comme fond pour un dessin : HighDesign propose un module d’édition d’image intégré permettant d’appliquer rapidement de nombreuses améliorations à l’image.

Pour modifier une image, sélectionnez-la et choisissez Outils ▸ Ajuster l’image : une fenêtre s’ouvre avec toutes les commandes permettant de modifier l’image sélectionnée.

La boîte de dialogue Ajuster l’image affiche un aperçu de l’image dans la partie supérieure. Les commandes sont regroupées en boutons de transformation, en boutons de filtres avancés et en curseurs de luminosité, de contraste et de saturation. Les options disponibles sont les suivantes : 

  • Transformer:
    • Mirror Horizontal, reflète l’image horizontalement sur son axe Y.
    • Mirror Vertical, reflète l’image verticalement sur son axe X.
    • Crop (Recadrage), coupe les bords de l’image en ne laissant que la zone sélectionnée.
  • Focus et couleurs:
    • Niveaux de gris, transforme toutes les couleurs en gris.;
    • Inverser, inverse toutes les couleurs du positif au négatif et vice versa.; 
    • Accentuation, améliore le contraste sur les bords.;
    • Flou, lisse l’image;
  • Luminosité, contrôle la quantité de lumière dans l’image ; 
  • Contraste, permet de régler le contraste entre les couleurs ;
  • Saturation, améliore la saturation des couleurs. 

Pour appliquer un filtre, appuyez sur le bouton correspondant ou déplacez le curseur. Les filtres de netteté et de flou peuvent être appliqués plusieurs fois. Tout filtre appliqué, dont vous pouvez avoir un aperçu dans la vignette, est stocké dans une image temporaire jusqu’à ce que vous appuyiez sur le bouton “Appliquer”, qui applique tous les filtres en file d’attente à l’image principale, tandis que le bouton “Annuler” efface la file d’attente des filtres. 

Le bouton “Rétablir l’image”, dans le coin inférieur gauche de la fenêtre, efface tous les filtres appliqués à l’image. 


Présentation du dessin

Il s’agit d’un outil de rendu 2D qui crée des images de haute qualité de votre projet avec des effets variés de couleurs d’arrière-plan, de stylo et de remplissage, de bordure et de marges, de filigrane et de taille et de résolution réglables. 

Cet outil applique non seulement un anticrénelage aux bords des objets, mais il permet également de personnaliser la taille d’impression et la résolution de l’image et offre des options d’arrière-plan, des cadres et des effets de couleur pour réaliser des présentations à fort impact de vos projets. Le résultat est une image qui peut être exportée dans l’un des formats de fichiers graphiques pris en charge. Pour définir toutes les options, sélectionnez Outils ▸ Rendu pour ouvrir la boîte de dialogue des paramètres de l’image. 

Set Image Options  

Utilisez cette boîte de dialogue pour définir les effets visuels et les options pour créer une illustration. 

  • Effets d’image : cliquez pour afficher les options graphiques. 
  • Bordure : option pour afficher une bordure, couleur et épaisseur de la marge. 
  • Filigrane : options pour ajouter une signature numérique ou un filigrane à l’image. 
  • Taille de l’image : options permettant de définir la résolution et la taille de l’image. 
  • Aperçu de l’image obtenue. 
  • Boutons permettant d’enregistrer les paramètres actuels en tant que nouveau thème ou de supprimer le thème sélectionné. 
  • Liste des thèmes chargés. 

Une fois tous les réglages effectués, si vous souhaitez enregistrer les paramètres actuels en tant que nouveau thème pour une utilisation ultérieure, il vous suffit d’appuyer sur le bouton “+” près du menu des thèmes pour le voir apparaître dans le menu avec le nom souhaité. Cliquez sur “Ok” pour confirmer et ouvrir une nouvelle fenêtre affichant l’image résultante ou sur “Annuler” pour quitter ce dialogue.

Effets d’image 

Les options permettant d’appliquer des effets graphiques à l’image sont les suivantes : 

  • Contexte: 
    • Par projet : définit l’arrière-plan à la même couleur que celle utilisée dans la fenêtre principale du projet ; 
    • Couleur unie : utilisez le bouton pour sélectionner la couleur; 
    • Dégradé horizontal : sélectionnez les couleurs gauche et droite du dégradé; 
    • Gradient vertical : sélectionnez les couleurs supérieure et inférieure du gradient.; 
    • Image, mosaïque : dessine une image comme arrière-plan ; les images plus petites que l’image de destination sont mises en mosaïque ; sélectionnez l’image sur le disque.; 
    • Image, redimensionnée : dessine une image en arrière-plan en l’adaptant à l’image de destination. Les images sont mises à l’échelle de manière non proportionnelle ; sélectionnez l’image sur le disque. 
  • Couleur du dessin: 
    • Par projet : conserve les couleurs originales du dessin ; 
    • Couleur personnalisée : choisissez la couleur dans le menu contextuel. 
  • Couleur de remplissage : 
    • Aucun; 
    • Par projet; 
    • Monochromatique : choisissez la couleur dans le menu contextuel.; 
    • Niveaux de gris; 
    • Sépia. 
  • Type de ligne : sélectionnez le type de ligne dans la liste chargée. 

Filigrane 

La fonction Filigrane de l’outil “Rendu” vous permet d’ajouter un filigrane textuel à l’image : les options de style de texte comprennent la police, la taille, le style de texte (gras, italique, souligné) et la couleur. Grâce à un menu, il est possible de définir la position du filigrane dans l’image. 

Options de taille d’image 

Dans ce volet sont regroupées toutes les options permettant de définir le format, la taille et la résolution souhaités de l’image obtenue. 

  • Préréglé : choisissez la taille qui correspond le mieux à vos besoins parmi les nombreux formats standard proposés dans le menu ; 
  • Taille en pixels : utilisez les champs pour entrer votre taille d’image personnalisée en pixels : cliquez sur l’icône pour verrouiller le rapport souhaité ; 
  • Résolution : définissez une résolution de 72 dpi pour la publication Web ou les présentations, tandis que les résolutions de 300 dpi ou plus sont les meilleures pour la sortie imprimée ; 
  • Taille d’impression : vous pouvez définir la largeur et la hauteur de l’impression, en utilisant le menu de droite pour définir les unités. 

Exportation d’images 

L’image résultante est affichée dans une nouvelle fenêtre qui offre quelques boutons, dont les boutons de zoom : appuyez sur le bouton “Enregistrer” pour exporter l’image sous forme de fichier TIFF, PNG ou JPEG ou sur le bouton “Copier” pour copier l’image dans le presse-papiers. 

Vous pouvez également glisser et déposer l’image sur la fenêtre principale du projet pour l’insérer dans la feuille en cours. 

Was this article helpful to you? Yes 1 No 1

How can we help?